Video much too bright on SDR material

Today I received the Vero V. No problems during setup and updating, everything went very well.

But playing SDR content is much too bright. When there’s a black background, my screen lights up grey. I’m using a 4K LG OLED display which is connected to the Vero V with a good quality HDMI cable. In fact, I did a drop-in replacement with the Vero 4K so it’s using the same display and cables.

Strange thing is: HDR content is just fine! The background is black, as it’s supposed to be. I have tried experimenting with the display settings, but that did not make any difference. Is there some setting that I haven’t found yet, or will there be a workaround?

Are all SDR videos affected? Check you haven’t set contrast or brightness with the on-screen controls. Check you have set quantisation to limited in display settings and check the settings on your TV (SDR will be independant of HDR settings).

Just got my Vero V today and I have the same problem. Also on LG 4k OLED.
looks as if tv is set to 0-255 rgb levels but vero to 16-235 or something like that. flipping the rgb full range toggle in settings makes zero difference.
it’s also visible in the GUI itself, but that is less obvious.

I’ve had a vero 4+ on the same tv-hdmi input that shows everything just fine (and still does when I connect it again).

Thanks for your help! But I don’t understand what you mean by ‘on screen controls’. There are no on-screen controls for brightness and contrast, as far as I know. I can go into the video settings menu while playing a file, and there I can dial down the brightness, but that only works for the file I’m playing. Is there a brightness setting for all files? I haven’t been able to find that in the menu.

But I also checked the brightness control on the TV and it seemed indeed a little high, so I dialed it down and now the picture is fine. Perhaps my TV is defaulting to a standard brightness when it detects a new playing device. I will check tomorrow by connecting the Vero 4K and see what was the setting there.

Just to be sure: To unset ‘Use limited color range’ at settings → system → display doesn’t make a difference?

Check through this:

Normally when receiving YUV/YCC signals a TV will not be capable of switching to full-range video.

The problem has been fixed. Checked the ‘limited’ setting, it was off on the V and the 4K. Looks the V is brighter than the 4K by itself. Dialed down the brightness on the TV. Picture is perfect now.


Yes - the tonemapping algorithms are different (but improved) on Vero V.

Glad this is solved now.

Hmm I really think something is still wrong. If I set my LG (CS6) oled to limited range for RGB everything is perfect again. So it really does look like the Vero 5 is sending out limited RGB values, regardless of the settings. (as I said, toggling the swich in kodi makes no difference).

I could leave it like that, but full range exists for a reason :slight_smile:

Is there a way to actually check the rgb range that the vero outputs? or a method to really force it to full range?


We will check it.

Yes, the reason is to support PC monitors, not to improve VQ. What do you hope to gain with full-range? The difference from limited range should be negligible, and generally displays will only support full-range if set to RGB input instead of YUV/YCC. RGB output will drop to 8 bits in certain circumstances which will cause bigger issues (banding) than using YUV limited range.

It could be your display is detecting the switch and switching itself accordingly. FYI HDR video is always output as limited range - that’s what the standard requires so what TVs expect.

Try toggling the switch on your TV. Or cat /sys/class/amhdmitx/amhdmitx0/config

Full range RGB is only used for devices like PC monitors, and even in the best case scenario, full range will give you worse picture quality than limited, if the display can handle both. The video is encoded as limited range YUV. A television (as opposed to a monitor) is optimised for a limited range YUV input signal. There shouldn’t be any conversions anywhere in the pipeline.

Thanks everyone for your replies!

I checked the output of the cat command and I can confirm that the output switches between limited and full range when toggling the switch in kodi.
I was indeed worried about banding being worse on limited output, but it seems things do not really work the way I thought they did. Thanks for educating me!

I’ve put my TV on auto rgb-range, everything looks perfect and I will no longer worry about full/limited range regarding VQ. :slight_smile:

Thanks again!

1 Like

I’m getting the opposite. All of my sdr stuff is too dark (or at least way darker than the 4K+ that it has replaced).