Video orientation problem


Here is a tricky one (I think so)
I have a bunch of videos 4k60 h265 and one of them is, for some unknown reasons rotated 180 (upside down) by my Vero4K. But no on Windows, all the videos are the same orientation
And whatever I do, the Vero4K is playing it upside down.
I change de metadata to 180, 90, 270, 0 and it still play upside down on the vero4k (but on windows my metdata change make it play on whatever side I want : upsidedown, 270, 90 …)

There is an option to select, with the vero4K in the video setting, if I want to play the orientation with the metadata, or 90 or 180. Whatever I choose it still the same (is that option actually works cause whatever movie I put on I can not change its orientation)

So I guess there are two questions in this post
How do I activate the orientation change in the video setting on the vero4k?
And what parameters in my specific video should I change so it can read it with a different orientation (without reencoding) . The Vero4k does not seems to read the metadata rotation parameter.

Thank you


What metadata did you change?
Can you post the MediaInfo for the file?

Complete name : 808_orig.mp4
Format : MPEG-4
Format profile : Base Media / Version 2
Codec ID : mp42 (isom/mp42)
File size : 226 MiB
Duration : 44 s 864 ms
Overall bit rate : 42.2 Mb/s
Encoded date : UTC 2019-12-30 11:08:53
Tagged date : UTC 2019-12-30 11:08:53 : 9

ID : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main@L5.1@Main
Codec ID : hvc1
Codec ID/Info : High Efficiency Video Coding
Duration : 44 s 833 ms
Bit rate : 42.0 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Rotation : 180°
Frame rate mode : Variable
Frame rate : 60.000 FPS
Minimum frame rate : 44.401 FPS
Maximum frame rate : 60.322 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Bits/(Pixel*Frame) : 0.084
Stream size : 225 MiB (99%)
Title : VideoHandle
Language : English
Encoded date : UTC 2019-12-30 11:08:53
Tagged date : UTC 2019-12-30 11:08:53
Color range : Limited
Color primaries : BT.709
Transfer characteristics : BT.601
Matrix coefficients : BT.709
mdhd_Duration : 44833
Codec configuration box : hvcC

ID : 2
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : mp4a-40-2
Duration : 44 s 864 ms
Bit rate mode : Constant
Bit rate : 256 kb/s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Stream size : 1.37 MiB (1%)
Title : SoundHandle
Language : English
Encoded date : UTC 2019-12-30 11:08:53
Tagged date : UTC 2019-12-30 11:08:53

I tryed to change the “Rotation” metadata
But whatever I put it’s stay the same

Also, any reason why the orientation change in the video setting on the vero4k doesn’t have any effect (on any video)?


Does this only affect H265?
I thought H264 may be an issue but wouldn’t suspect H264 to be.


Yes, h264 also doesn’t respond to orientation change in the video setting
I never used this option before so I don’t know if it is recent problem

Any news about the orientation change in the video setting? Is it supposed to work?

It should work but it doesn’t. I’m not sure if it’s easily fixable.

I have some ideas on how to fix this.

Is any hope that after 4.9 kernel becomes officially released, H265 videos orientation will work and it play not upside down?

H264 videos orientation works on 4.9 testing kernel.
But all H265 on 4.9 testing kernel works upside down as described here:

When playing the file, you should be able to select the orientation manually instead of ‘from metadata’.

For H264 video I can change orientation. Like example if video is made like example in portrait mode, then I change manually orientation to 90 and it shows video in portrait mode (vertical I mean)

But for H265 videos manually orientation not work. I can put manually like example 180 or 90 but it is not changing. Changes just 270, but if video is made normal(not in portrait mode ) then it plays vertical.

I am on 4.9 kernel. Not sure how it is on stable.