Video playback freezing after a few seconds

Raspberry PI 4 B
Some videos work fine and others will freeze when trying to play. No I’m not streaming the files I’ve seen a lot of forms with people having this issue while streaming the file over the network. I’m playing it directly from a USB 3.0 4TB SSD passport.
Normal .mp4s work and play fine but some .mkv freeze up. I don’t know if it’s the way the audio is encoded or what but I can’t find any information on this topic with the videos being played directly from a source instead of over the cloud.
Any help would be greatly appreciated.

You would need to provide some more information (mediainfo) on the files that are not playing. If your trying to play Hi10P stuff that is known to be problematic. Some logs may be helpful as well…

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

The log after 2 reboots:
Video Metadata:

Change your UI resolution to 1080p 60hz and see if that fixes your issue.

UI Resolution or display resolution? I’m not seeing any display settings just for the UI

There is just the one resolution setting…

We recommend people with 4K TVs set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate>Always

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K.

*Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Well thank you for the help. Doing what you suggested made UI animations a lot smoother and less delay with the remote and the desired action. Didn’t fix the movie though. And I did indeed check it on my computer to make sure it isn’t just the file it works fine on my computer.
Also could not locate "force 4:2:2 colour in display.

I think that’s only a Vero 4K setting, not Pi. But in any case you only need it if your TV is struggling to maintain a stable HDMI connection, giving you signal drop-outs.

It’s not that it drops out. Its just the media playback. I can still mess with the gui while the video stutters than freezes. Checking and unchecking passthrough unfreezes it for a little till it does it a second or two later.
I’ve played the same media through an xbox and it played just fine. It’s not the TV dropping signal. It’s something up with the pi. Even trying to play a 720 mkv freezes up.

Either a bad PSU or HDMI cable.

I grabbed that exact file and played it on a RPi 4 2gb for the first 20min without incident. That drive it’s playing from is bus powered I’m assuming which may be an issue. I would try a different larger PSU if you have one laying around or possibly just copy the file to either the SD card or some other storage that is not pulling power from the RPi to test.

1 Like

Interesting. 4TB external SSD could cause quite the draw. Ill throw another film I run into issues with on a flash drive and try that… If it works then sweet its nothing wrong with the pi.

Update. I hooked the hard drive up to the router and accessed the movie through there. Same issue.
Threw an x files episode I’m having the same issue with on a flash drive and tried playing it. Same issue. The files My pi comes to a crashing halt to are ACC encoded for audio. Everything else plays em fine.

In your Kodi audio settings maybe try changing your “output configuration” from optimized to best match and see if that makes a difference.

No fix my good sir.

I would suggest uploading some new logs so we can check the settings have been changed and see if there are other indications as to why you are experiencing a problem

Has this issue been resolved?
I have same issue, here. Playback is freezing after a few seconds for some Movies, while others work fine. GUI is fully responsive on the freeze, so I’m able to stop the movie and exit to the menu, like in @that80sdude88 case here.
I have confirmed the movie file itself is not a problem, it plays OK in other devices.
I have reproduced the issue, after enabling debug logs and rebooting twice as you suggested above.
Here are the logs:
Could you please check what’s wrong?

Just to add that the issue happens in some Movies that I have already watched in OSMC in the past. So it looks like being related with latest release(s).

I’m not spotting it. Can you test that same file playing from a thumb drive directly attached to your Pi to try to isolate if it is a networking issue or not.

I played the same movie file, this time from the local storage (SD). The playback froze again few seconds after starting.
Here are the new logs:

I found the problem in my setup.
The Setting: System>Audio>Number of Channels = 5.1 caused this.
After changing it to 2.0, the Movies are playing OK, no freezing.

I observed that with setting 5.1, the movies with Audio AAC 5.1 are freezing and the movies with “Dolby Digital 5.1” play OK.
With setting to 2.0, all movies play OK.

I don’t know if this freezing is expected behavior, or need some fixing…
I’m willing to provide more logs or anything that can help to solve it.