Video playback not starting after idling

Hi guys,

I have a bit of an odd issue, where after a power cycle, any video will play normally and if I continue watching things without any real idle time, things keep working. However, when I am not playing something, and come back to watch something later on, the video does not play and I am, stuck at the “loading” animation. Sometimes, I can still press the stop button, but this usually just freezes the entire interface, where I am forced to do a power cycle. After the Vero boots up, I am again in the same cycle, where I can watch something without issue.

I have also noted that after a video playing some time (Lets say halfway through a movie), I am not able to perform any kind of skipping as it freezes the video and gets stuck on loading, whereas on a clean boot, I can fast forward/go back as much as I want.

For the record, I am running nightlies, so this may have something to do with it, but I have had this issue for over 2 months now, and since I havent seen anyone else mention these kind of problems doubt it’s the source of the issue.

I have created logs which can be found here:

This log contains a play of a tv show, a couple of minutes of idling, followed by an attempt to start another show which only gave me the “loading” indicator.

Does anyone have any idea what the root cause of this issue is?

Thanks in advance!

Please enable debug logging so we can see the issue in more detail.


Hi Sam,

I have created new logs where debugging is enabled:

This log was taken from the same “broken” session as the previous, just that debugging is now enabled when I tried to start a new show.

You will probably have to look at the Kodi Old Log, as the GUI completely froze after I issued a Stop command while the loading icon was spinning and I was forced to power cycle the device before I could use the log uploader.

Thanks in advance for taking a look.

See INFO: CFileCache::Process - Source read didn’t return any data! Hit eof(?)

Does this happen with local playback (i.e. from a USB or eMMC)?

I’m not sure how I will test that properly, but I will give it a go.

Are you suspecting a network timeout/issue somewhere?

Looks quite a bit like that.
Maybe try to run a ls in parallel in a ssh session watch ls -lah /mnt/nas/Series/

I have attempted to run a file from a USB stick, and it results in the same issue:

I have tried to start the Blindspot (around 17.05) episode with the same result as over the network.

It looks like once the issue (whatever it is) occurs, no playback will work. I am guessing the same for streams (Youtube, Twitch) will be true.

I have to say, I was “lucky” during these tests, as the GUI did not lock up on me trying to play something.

I hope something can be found in the logs.

Regarding the following:

I did not see any change in the listing. It simply kept showing the contents of the folder.

Thanks again!

It looks like Kodi v17.6 has a bug where if there is a drop in connectivity / buffer hits EOF unexpectedly, the decoder handle is not released. This makes subsequent playback attempts fail.

I understand this to be fixed in Kodi v18, however your device shouldn’t be losing its network connection to the NAS.

Can we have some more details about the connection? It looks like you are using an external Ethernet adapter. Do you experience this problem with the internal adapter?


That would explain at least something in this case :slight_smile: One thing though, I am running the latest Leia nightly, so I should not have this problem?

I am indeed using an external Ethernet adapter

My NAS is simply a Windows 10 machine serving the files from a shared drive. My drives to sleep after 20 minutes of inactivity, could this be a problem? Shouldnt Kodi wait for the drive to be available?

I have, for now, switched to the internal connection, and will also report back on that once I have news.

Thanks so far!

Ok – I’ll check that out.

If you could confirm, that would be interesting

Hi Sam,

The same issue happened now on the internal connection, so that’s not the reason this is happening atleast. If you want, I can supply you with logs again, but I guess they will tell the same story.



You could take a look at autofs

Thanks Tom.

Did you update to v18 recently?
Did it happen before this?

Are you able to revert to v17.6?

I’ve basically been running nightlies since… forever. I believe the issue was introduced for me somewhere in December.

I don’t mind to downgrade to 17.6, but am unsure what the best way to achieve this is. If you can give me any pointer, that would be helpful :slight_smile:

Then it’s possible something’s changed in your environment to cause this.
You could try installing a November version of v18 and see if it helps?