Video playback randomly stops

Hello,

I have a Raspberry PI 2 with the latest version (RC3) of OSMC.

On some videos, playback stops at random intervals and goes back to the menu.

Any ideas how I can stop it?

Thanks,

Carl

Please upload full logs and MediaInfo output

S

check if you have bad blocks in your HDD

Sorry, I am a novice. How do I get that information?

C

https://osmc.tv/help/wiki/logs

Hi.

The logs are at [here][1]

Regards,

Carl
[1]: http://paste.osmc.io/iwenoxisoq

In your advancedsettings.xml why do you have buffermode set to 1 and readbufferfactor set to 1 ?

You appear to be using nfs, and buffermode 1 means that all filesystems including nfs will be buffered rather than just internet streams, but at the same time you have readbufferfactor set to 1.

Although 1 is the default readbufferfactor for vanilla Kodi, 4 is the default for OSMC and in our opinion it should never be set as low as 1 as it can cause buffer under-runs to occur which result in playback stopping.

So please remove readbufferfactor entirely or set it to a value between 4 and 10.

I also see that you are using wireless - are you sure that your wireless connection is fast and stable enough for the bitrate of videos you are streaming ? Do you have problems with all videos or only some, and what bitrate are the ones you have trouble with ?

Try my readbufferfactor suggestion first, if you are still having problems and there is a way you can temporarily plug your Pi in via an Ethernet cable please test that so we can determine if the wifi connection is the issue.

Looks like the video starts playing at line 1818 and stops at line 2078

I think the problem is around line 1991: 08:12:20 T:1634526240 ERROR: Read - Error( -14, read call failed with “F” )

Presumably the problem is with the NFS mount? If so, is there any way to find out what that problem was?

Regards,

Carl

I would rule out Wifi first if at all possible. It’s the most likely cause for intermittent network connectivity.

I’ve tried removing the readbufferfactor and changing it to 10, but it hasn’t made a difference.

Doing a bit of research, I was going to use “wavemon” to check my wifi signal, but do “sudo apt-get install wavemon” just gives me “Unable to locate package wavemon”.

Is there some other way to check the wifi signal?

Regards,

Carl

connmanctl services will give you an idea of signal strength, as will the GUI.

Did you run sudo apt-get update first?
S

Hi.

Doing the “sudo apt-get update” allowed me to then get wavemon (I had assumed that since I had the latest version of OSMC I wouldn’t need to update first).

That showed one issue with my wifi - I have two wifi adapters in my house and for some reason the PI was connected to the one furthest away. Do you know how I change the agressiveness with which the PI changes WIFI?

Thanks,

Carl

Bumping to say I have a very similar issue. It’s been happening for several months but as I don’t use it very frequently right now I haven’t been too bothered yet.

However for me it’s all videos. I get between 5 and 20 minutes of playback and then I get bumped back to the screen I selected the video from. I don’t know exactly when it started as one month it was working then the next I tried using it and it was not. The only thing in my entire set up that had changed during this time was moving my subnet from one address to another (wasn’t exactly clean…). At first I thought maybe some left over setup from that was the problem, but after reflashing with a brand new install the same issue presented itself.

Is there some kind of log which will show why a video exited playback?

EDIT: So sorry, read the dates as May 15th not May 2015. Didn’t realise the post was so old or I would have made a new thread, should I still? Don’t want to spam the forum.

Yes, and provide logs so we have some chance at finding your problem.

To get a better understanding of the problem you are experiencing we need more information, including logs from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.