Video playback stops seemingly at random

I get between 5 and 20 minutes of playback and then I get bumped back to the screen I selected the video from. I don’t know exactly when it started as one month it was working then the next I tried using it and it was not, I believe it’d well over 3 months that it’s been broken though. The only thing in my entire set up that has changed during this time was moving my subnet from one address to another (wasn’t exactly clean…). At first I thought maybe some left over setup from that was the problem, but after reflashing with a brand new install the same issue presented itself.

I have some suspicions that how long an interval lasts before it kicks the video and goes back to the menu has to do with the amount of data transferred. ie. larger files will playback for less time than smaller files of the same duration. And I did manage to get one movie to playback twice to the exact same moment before quiting, however the same movie later lasted 3 minutes less time than that so it’s not really conclusive…

Logs here,

I managed to find this line, ‘12:18:33 110.880371 T:1707078640 DEBUG: CNFSFile::Close closing file volume1/video…’
But everything before it is gibberish to me so I don’t know what caused it to close.

PS. If there are any skin related warnings or something in the log (didn’t see any but didn’t look) ignore them please, this same issue was happening on a fresh install using the default OSMC skin.

Can you copy a file that exits early and try playing it locally (e.g. from sdcard/usb stick)?
I suspect it is a network error, and this will help narrow it down.

How are IP addresses being allocated? DHCP? static? Any chance another device on network has same IP address as Pi?

I (personally) watch all my movies on my computer from the same device, I’ve watched this particular film twice. Other people are the ones that use the Pi which is why I didn’t notice for so long. No issues at all playing across the network with my PC.

I’m pretty sure the Pi gets its IP by DHCP, I cannot think of a device that could also be using its IP and my router’s list of devices and their IPs seems perfectly normal.

Well, I ran the many months pending update for my DiskStation which ironically I had been avoiding because I didn’t want to introduce instability (if it ain’t broke…). I’m not sure if the update itself fixed something or it indirectly did something but I did get a movie to play all the way through afterwards. I’ll need to confirm but I’d probably consider this issue closed and probably not an OSMC issue.