Video plays fine in VLC but not in Vero 4K


I have an .MP4 video (x264-AC3) which plays fine under VLC but when I try to play it with Vero 4K the sound is ok but the video doesn`t keep up. It is playing very slow, looks like Vero does have a hard time to read the file. But even if I convert the video file to .mkv and/or x265 it does the same.

Any help will be very appreciated.


It would be helpful for you to provide mediainfo for this file and logs showing playback.

The MediaInfo output of the file would be useful so we can check it



Here is the MediaInfo output:

Complete name : D:\Downloads\Pierre-Luc Pomerleau.2022.VFQ.1080p.WEB.x264-QCx.mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom (isom/iso2/avc1/mp41)
File size : 1.11 GiB
Duration : 43 min 55 s
Overall bit rate mode : Variable
Overall bit rate : 3 625 kb/s
Writing application : Lavf58.76.100

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4
Format settings : CABAC / 4 Ref Frames
Format settings, CABAC : Yes
Format settings, Reference frames : 4 frames
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 43 min 55 s
Source duration : 43 min 55 s
Bit rate mode : Variable
Maximum bit rate : 5 250 kb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 29.970 (30000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Source stream size : 1.07 GiB (96%)
mdhd_Duration : 2635666
Codec configuration box : avcC

ID : 2
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : mp4a-40-2
Duration : 43 min 55 s
Source duration : 43 min 55 s
Source_Duration_LastFrame : -11 ms
Bit rate mode : Constant
Nominal bit rate : 128 kb/s
Maximum bit rate : 128 kb/s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Source stream size : 40.2 MiB (4%)
Default : Yes
Alternate group : 1
mdhd_Duration : 2635701


This is very strange. Have you tried playing the video in software with H264 acceleration disabled?


Yes I disabled it and it plays fine as well.

Make sure the resolution is set to 1080p in the settings. video will still play at 4k if its 4k

The weird thing is even if I convert the video to .mkv, h265, .avi etc… it does the same thing.

How did you convert it, i.e. which tool and settings?

I don’t trust the audio track, and if you muxed that as is and only converted the video, then the issue may be the audio.

There was someone on this forum some time back that had some obscure old video that would play in VLC but not much else. I played around with it and couldn’t get a transcode from Handbrake that worked correctly. Oddly enough, when transcoding it with VLC (previously I didn’t even realize it had that ability) I did get a file that would play correctly in everything. Why, I have no idea, but it may be worth a try.

Both should use ffmpeg as the underlying transcode mechanism, but VLC may be introducing some corrective options or even be encoding things differently that corrected the problem by accident.