Video plays like its fast forwarding. Ends abruptly

Hello there fellow Vero’ians

Running latest and greatest update on my Vero 4K.

Experiencing a weird bug.
When I start to watch a recorded TV show (can’t see any pattern here - happens to random files - both manual recordings and scheduled recordings).
The video plays like its fast forwarding - this goes on for 3-5 seconds - then playback stops.

One common denominator is that the recordings that behave like this - have an obscure offset time.
It’s always set at 6.37.43 (6 hours, 37 minutes and 43 seconds)
See screenshot:

The only way I can watch these recordings are by doing the following:

  • pause the video (it keeps playing for a while despite being paused)
  • keep skipping backwards until I’m below the real end time (in the screenshot above - it would be 36 minutes)
  • then I am able to play back the video in normal fashion.

The same files play back without a hitch on a Windows machine - with Kodi installed.
(If needed - I can create a torrent, and upload a sample).

Any suggestions on how to fix this.

I haven’t seen this behavior in previous builds of OSMC.

Logs provided:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

First post edited - logs now provided.

Can you send me a magnet and a sample that reproduces the problem?

It could be a PTS overflow issue


PM sent with magnet

I’m downloading it.

While I grab that file, can you try the staging repo?

To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Thanks Sam.

Sure - I will give it a go

Hi again Sam.

That did the trick!

Implemented your suggestion - and have tried playing back several files - which had this particular issue.

Now playback works without a hitch :wink:

Thx a bunch - and Happy New Year!

I noticed this a little while ago, daftly I presumed it was something to do with my TVHeadend setup, it was only on 2 recordings, if I fed them through FFmpeg with:

ffmpeg -i input.ts -c copy output.ts

it fixed the issue and the recording could be played back.

Regardless, good to see its fixed Sam.

Glad to hear this.