Video returning to Menu?

I am running OSMC Pi3b+ using a samsung class 10 32gb sd card, I have installed via the appstore, Smb shares, Tvheadend, Transmission. I am finding that on some mkv file playback there is a glitch in playback and returning to menu(Tv Show) but then the file will continue to play in the background, I have enabled the debug log and it is does not appear to be a cpu or memory issue.

I am quite familiar with kodi and have tried most settings, I think, with and without audio passthrough, I’ve tried hardware enabling hardware acceleration, I have created an advanced settings.xml and created 50 mb buffer, the problem still persists.

I have tried the same files that this is happening on a HTPC windows 10 machine on kodi and all is ok, so it seems certain to be a problem with OSMC somewhere, I’m hoping a setting I have missed.

Any help with this would be great its driving me mad, mainly because I reckon there is something simple I’m missing I just done know what it

Sharing that debug log via MyOSMC - Log Upload would be a first step

I have created a debug log as suggested I managed to re-create the exact issue hopefully this will shed some light on the problem.

You might need to give some more input what you have done when.
I can see you pressed several times the right key to skip forward and the you pressed backspace. Backspace would return to the menu with the movie continue in the background so that is exactly what you described above.

2021-01-11 11:16:23.224 T:1916346384 DEBUG: HandleKey: backspace (0xf008) pressed, action is Fullscreen

I forwarded to the part in the file where the mkv where the return to menu happens, it went past it then re-winded the video back to the point where I was certain it was going to happen.

I will upload a fresh debug log with the file just runnings its own course.

But at one point you pressed backspace?

I have another debug log within the first 5 minutes of the file, the same error occurred twice.

Well you have this
2021-01-11 14:26:53.118 T:1366266080 DEBUG: Readrate 1661000 is too low with 1664954 required which could indicate a problem with the USB Drive. Maybe try to copy the file to the SD Card and play it from there to see if the same problem happens.

On the otherhand I see that you within the 5 minutes of playing the file twice pressed backspace which would cause the return to menu and play in background.
So once more the question have you pressed backspace on purpose twice?

I’m using a brand new 12tb external Wd mains powered hard drive to play the file so find that a little strange unless of course the hard drive is a dud, I will try a usb dongle non the less.

I pressed the back twice to go back through the menu system, me being lazy I suppose I have a harmony 650 with flirc, I didn’t think much of it, but yes you are correct that would bring my to the menu system.

Why not just copy the file to the SD Card? Is it too big for the SD Card?

It appears that you was on to something with the backspace presses which got me to thinking how sluggish flirc is with kodi worse than what is or was when I used to use it with my HTPC.
To cut along story short I unplugged the flirc and all is working OK now.

So it seems that flirc, harmony 605 and the Pi3b+ wasn’t playing well together.

Thanks for the help :+1: