Video starts buffering after around 45 minutes

I have OSMC installed on a Raspberry PI 3 model B+. I use this one mainly for watching online videos through several addons. Every video, regardless of the plugin I use, works fine for the first ± 45 minutes. After that the video starts to buffer and lag until I exit and resume the video after which I get smooth playback for another 45 minutes. I have tried a cache memorysize of both 100MB and 0. Both yield the result above. Since the logs seem to indicate some kind of audio issue large audio sync error I’ve tried activating audio throughput in the system settings. That also did not make a difference.

My setup is as follows. I have 2 raspberry pi’s and a TV decoder all connected through HDMI to a TV. The TV is connected to a receiver through an optical cable with a 7.1 speaker set.

Logs can be found at . Any clue what is causing this issue?

Is local playback OK?

I normally never play anything locally. But I’ve just copied a movie to the SDcard on which OSMC is installed. No issues whatsoever after an hour playtime.


You can safely increase the ram used to 150mb on:


Also readfactor 10 may be too hight for your networks bandwidth. I would start at 5 and try increasing in stages if issues continue. 5 has always been adequate for me.

Thanks Tom.

Thanks for the suggestions. I believe 0 is the recommended memorysize for low RAM devices such as the raspberry Pi so that was my initial value. Readfactor 10 did not cause issues regarding network bandwidth on my other Pi. But I’ll give your suggestions a shot and I’ll report back.

I’ve just tried a video of about 2 hours. Behaviour stays the same unfortunately.


Sync playback to display: true

May not help, but can you please disable this. As you have passthrough enabled, but sync to display disables this.

Thanks Tom.

The first test result shows that disabling that option indeed fixes the issue. Thanks for your help! Could you tell me a bit more about why this would cause the buffering issues I experienced?

1 Like


I didn’t, I just know it breaks passthrough, which from looking at your other settings; wasn’t good.

Thanks Tom.