Video stutter - like slo-mo

On a couple of movie files the display seems to move in slo-mo with the audio sounding as normal. When i press pause, the audio stops, but the display moves on for a few seconds until it stops.

Resuming the video it is still the same. 2 files this happens on is:

Captain.America.Civil.War.2016.1080p.BluRay.DTS-HD.MA.7.1.x264-iFT.mkv - 20gb
The.Long.Kiss.Goodnight.1996.1080p.BluRay.REMUX.VC-1.DTS-HD.MA.5.1-EPSiLON-4P.mkv - 18gb

A search of the forum for similar issues:

  • Adjust display refresh rate: Set to “On start/stop.” - done.

  • Also, GUI set to 2160P. It should always be set at 1080P - couldn’t find this setting (using Metropolis skin)

We recommend people with 4K TVs set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate>Always

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K.

*Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Settings>System>Display>Resolution> 1920x1080p - was already set to this.
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate>Always - changed to this, no difference.

No idea about the whitelist - haven’t touched that since purchase.


Whitelist looks full of different resolutions - but no idea what i am doing there, so didn’t want to mess anything up, so left it as is.

Logs posted in 1st post.

Ty :slight_smile:

Did you solve your problem ?
On what device are you playing this file “The.Long.Kiss.Goodnight.1996.1080p.BluRay.REMUX.VC-1.DTS-HD.MA.5.1-EPSiLON-4P.mkv” ?
Because I have the same problem with VC-1 remux, on RPI4 it doesn’t work very well, the CPU is not fast enough, if it’s RPI 2 or 3 you maybe have to activate the VC1 codec.

1 Like

Not solved :frowning:

Using a Vero 4k+ with a HDD connected. Vero > Denon AVR > HDMI > TV

Can you post some new logs?

Any updates/fixes to this issue? I’m having to obtain other versions of movies/tv shows as some files are unwatchable.


Thanks for your patience.

I can immediately see that VC-1 playback isn’t being hardware accelerated, so it will indeed be laggy as it’s being played back in software.

2023-02-23 18:02:03.368 T:3037    DEBUG <general>: CDVDInputStreamFile::SetReadRate - set cache throttle rate to 3392724 bytes per second
2023-02-23 18:02:03.368 T:3037     INFO <general>: Opening stream: 0 source: 256
2023-02-23 18:02:03.368 T:3037     INFO <general>: CVideoPlayerVideo::OpenStream - Creating codec: 70
2023-02-23 18:02:03.368 T:3037    ERROR <general>: AML: no proper permission, please contact the device vendor. Skipping codec...
2023-02-23 18:02:03.368 T:3037    DEBUG <general>: CDVDVideoCodecAmlogic::Dispose called
2023-02-23 18:02:03.368 T:3037     INFO <general>: CDVDVideoCodecFFmpeg::Open() Using codec: SMPTE VC-1
2023-02-23 18:02:03.375 T:3037    DEBUG <general>: CDVDVideoCodecFFmpeg - Updated codec: ff-vc1

This is because your system hasn’t updated properly:

Setting up vero3-mediacenter-osmc (19.5.0-15) ...
dpkg: dependency problems prevent configuration of vero364-kernel-osmc:arm64:
 vero364-kernel-osmc:arm64 depends on vero364-image-4.9.269-21-osmc; however:
  Package vero364-image-4.9.269-21-osmc:arm64 is not configured yet.

dpkg: error processing package vero364-kernel-osmc:arm64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of vero3-device-osmc:
 vero3-device-osmc depends on vero364-kernel-osmc:arm64; however:
  Package vero364-kernel-osmc:arm64 is not configured yet.

dpkg: error processing package vero3-device-osmc (--configure):
 dependency problems - leaving unconfigured
Processing triggers for mailcap (3.69) ...
Processing triggers for libc-bin (2.31-113) ...
Errors were encountered while processing:

Can you try checking for updates via My OSMC and installing them when prompted?

This will solve your problem


1 Like

That’s great you have identified the issue - ty! However, the Vero is set to update automatically and also when i did a manual update, it says there are no updates available? :frowning:

Do you know how to use the command line?

The issue has occurred because the device hasn’t been updated for some time.

I can give some instructions to force an update via the command line or you can reinstall using instructions here: Reinstalling OSMC - Vero 4K - OSMC.

Either way will get you up and running promptly


1 Like

I’m hoping I don’t have to reinstall - I have folders, settings, all how we like it, which was done over time.

I’m not an uber geek, but I can command line in using putty. So if the instructions to update are clear - I should be OK!



sudo systemctl start manual-update
1 Like

I’m now at work, but will try as soon as I’m home tonight.

Thanks again.

Using command line i typed your command - it just tabbed to the next line, is this normal? However, the movie files are playing now.

I have added a link to the latest logs and looking at what you say the error was, it now says “using Amlogic decoder VC-1”

So i guess the issue is fixed?

Yes, the problem is now solved. Future updates should also be fine


1 Like