Video/voice lags every few seconds after update

After updating to osmc 4.1.3-2 watching TV or recordings are no longer smooth. Every few seconds and interruption in audio and video (maybe 100ms) is noticable. Any hints on how to debug this? No other system components have changed. Detailed setup diagram at Building a HTPC with Raspberry Pi2, OSMC and tvheadend | baloan

Does it help to re-enable omxplayer in Settings->Video->Acceleration ?

I’m also having this problem after the most recent update. I’ve timed it, and it happens every 10 seconds like clockwork. It isn’t major, it just seems like a dropped frame or something similar, but its regular enough to be annoying once you’ve noticed it. Ive tried quite a few combinations of sync and refresh rate settings, but the only thing which has fixed it for me was to re-enable OMXPlayer like you suggested.

Im running on a Pi 2.

Do you have an idea why its happening? It would be nice to have DVDPlayer working properly.


At my Raspi the same happens.
After restarting osmc everything is normal (without video/voice problems)?!

I’m also seeing this on my rapbpi B after the latest updates - although not as often as the OP.
During a 60 min TV show sourced from my NAS over smb it probably happens two to three times.
Video starts to go slow (like slow motion) and audio sync is lost and then after ten to twenty seconds the video suddenly changes to high speed until it has caught up and the audio sync returns.
Never saw this on earlier versions of OSMC or even in raspbmc.

I’m using the default settings so omxplayer is enabled by default (or at least when I go in to check that setting omxplayer is checked)

I still have little sound hickups, like some ms of silence every few minutes. Seems to get worse when far in the movie.

Same here. Video is fine, sound still has interuptions - after activating omxplayer.

Would be useful to narrow this down. Does the problem occur with:
omxplayer enabled/disabled
sync playback to display enabled/disabled
adjust display refresh rate to match video enabled/disabled
passthrough enabled/disabled

Does it occur at the same points when replaying the file, or random?
Are some files affected and others not?

Seems to appear with omxplayer on or off.

Sync display to video is on. Didn’t try to turn that off as I get stutter then.

I have audio passthrough enabled and my pi 2 directly connected to my LG TV that passes the dts bitstream to my Pioneer vsx 920 via optical out.

Also I think it is not always on the same points in the movie. But could be wrong here. Have to watch lotr a few times again :wink:

Please test this. We’re not looking for a solution for you, we’re trying to understand the problem.

Sorry. Not at home today. Thought that some stuff that I actually tried would also help.
Of course I will provide more info when I get the chance to test it.

here’s my log
immediately the prob appeared I stopped the video and uploaded the log.
Hope it’s helpful

I’ll try turning off sync display and see if that makes a difference

edit: OK - switching off “sync playback to display” makes no difference. Prob still evident

I’ve been having similar problems recently, primarily with the HDHomeRun video add-on on my RPi2.

I get the same issue since the update. Mine is about 3 second intervals.

BUT, not all video. The worst is actually SD Xvid with Mp3 2.0 audio. We watched a full HD movie (14gb) the other day with DTS (passed through to receiver) and no stutters at all.

Edit - just wanted to say we’ve just started watching another series which is SD Xvid but with DD5.1 sound, which my receiver decodes. This also works fine without sound/video glitches. Both this and the HD movie are on the same network NFS share, and are both larger files than the the SD series which has issues. I should also add that it worked fine pre-update. Maybe an issue with non-pass through audio only?

My settings are as follows. Let me know if you want to know anymore or test any options:

Adjust display refresh rate - disabled
Sync playback to display - disabled
OMXPlayer - enabled
MMAL - enabled
Support MVC video - enabled

My problem seems to be resolved after enabling omxplayer acceleration.

For these files does the framerate (“fr:”) look correct in the codec overlay?
I’ve got a file I need to investigate that shows a suspicious framerate (17) and has this effect. I wonder if it’s the same issue.

further to my prev post . . .
omxplayer is on
disabling MMAL makes no difference.
slowdown seems random. rewinding back to the same spot after correction and video plays fine.
adjust display refresh rate is off
enable passthrough - disabled

I don’t have access to a keyboard so not sure how to check the codec overlay??

Further to my last post, I think I’ve sorted mine. I have enabled “stereo upmix” and both of the series that were lagging are OK now.

Can anyone else test this? What does stereo upmix do exactly?

I’ve started getting the same issues since the recent update (video and subtitles freezing but audio going on, then after a while video speeds up until it’s caught up, and this happens every 3-5 minutes or so). I’ve used to have this before in raspbmc but it hadn’t happened in OSMC.

As the poster above said, turning on “stereo upmix” seems to have solved it. I was able to watch more than 15 minutes without it happening once, at least, in which time yesterday the lag happened four times or so.

I can’t immediately think why stereo upmix will help. Can someone upload a sample file that has this issue? I’d like to investigate.