Videos buffering, not watchable

I have a raspberry Pi 2 connected to my TV, then with wired cable to my computer.
It has been working very good until about 2 months ago, it started buffering sometimes but it was still watchable.
But now last week it keeps buffering like every 5 minutes, not watchable.
I have updated it to the latest version but with no improvement.
Do you have any tips what i can do?
Its installed with OSMC OS

Well providing a few more information want kind of files (codec) you are watching and also providing logs helps us.

OSMC has the easiest method of providing logs of any Kodi distribution we know of. We show you what to do here How to submit a useful support request - General - OSMC Please follow those instructions because without the information they provide, we really can’t do anything to help you.

I only watch .mkv files pretty much
Ok im at work right now but i will check the logs later tonight and provide the information! Thanks for replying so fast.

I have now uploaded the logs

MKV is only a container, it’s always important to know which codec is used. In this. case that is H264 for Video and DTS for Audio

There seems to be any issue with the synchronization. As a first step can you try to copy the file to the SD card and play from there to see if it make a difference.
Please also check your audio passthru settings.

Ok, i dont have a SD reader at home, need to take it to work then. Is it possible to transfer the file to the SD card from network?

Sure I assume you currently watching the movies from your PC via SMB, or? If that is the case just go to Settings → File Manager and you can directly copy the file

Alternatively install Samba from the App Store than OSMC is a NAS and you can transfer files onto it.

Yeah i am, thanks! And thanks again for answering so fast!!

After i put the file on the SD card it didint buffer at all, it played perfectly. I checked the Audio passthru settings but i dont really know what to look for, i tried changing a few settings but it made no difference. Where do i go from here?

Ok so that at least confirms that we need to check on the network side.
Suggest your check your network throughput with iperf

Ok, strange. I have the same problem… always worked perfectly until recently when it started to buff all the time, like you say.
I have done no changes at all, it just started to buff like this.

  • following *

Unless your device is buffering on local files as OP reports, then this is a different issue. Regardless, you should provide logs to confirm and assist instead of just “me too”

FWIW I have noticed the same thing, and I played a bit with this and also concluded it’s a network throughput problem. I have a couple of sizable x264 DTS mkv’s and it seems the bigger they are the worse the problem is. I however I haven’t ruled out that updates to my NAS and/or router haven’t had any effect. I’ve also considered that recent releases are steadily going up in quality/bitrate and as the file sizes increase the frequency of such problems may be pointing out the limits of the rpi2’s networking capabilities.

For instance, one release is x264 1080p 5.1 DTS but has more than 20 other audio tracks. This blows the file size up to near (EDIT: 20GB actually). The pi just doesn’t keep up… it’s not DECODING all this information but from my humble understanding it’s all still traversing the network. So I fired up handbrake and converted the file to only have the video and 1 audio track, which left me with a ~3GB file if memory serves: Plays flawlessly.

HOWEVER in seeing this thread I wouldn’t discount the fact that something on the network side has indeed gotten worse recently… because it does seem to have suddenly become a problem when it wasn’t before… I think I should maybe investigate a bit more closely.

Kinda weird you are struggling with buffering problems…

I can play blurays and 25GB+ mkv’s without any problem.

You have clearly not been on this forum for long or ever tried typing the term buffering into the forum search here.

OK I’ll clarify then: When it wasn’t a problem before FOR ME.

Hi, havent had the time to check it yet. But i was planning on doing it today, however im a bit “noob” at this and was wondering if u can help me.
How do i install iperf on the OSMC? I tried googling but i couldnt find any good guide. Or do i just install on the pc?
Should i install iperf3? Thanks in advance!