Viewing H.264 stream fom IP camera on RPi with OSMC 17-2

I cant get my newly acquired 1mega pixel IP camera with H.264 codec to display on the RPI with OSMC 17. A few years ago I use to be able to get an older camera (now dead) to stream to XBMC (the version just before Kodi came out). I thought that H.264 decoding was built into the hardware of the Pi. Ive put a strm file which works on ISpy ina windows pc into the files section on OSMC and turning on the visible logs it gives me a frame rate but no picture. Am I missing something here.

#EXTINF:-1, Test IP Cam[COLOR red]Full HD[/COLOR]

This is what I have in my .strm file, and it works fine on a HIK Vision 3MP IP cam.(Max 2MP on the Pi but 3MP on Vero 4K)
The Pi can decode H.264 by hardware, so it should not be the problem.

Very similar to my stream file - rtsp://user:password@ is what I’m using using on the PC with Ispy. The HJT camera instructions give this format for the 720p H.264 stream for the camera I’ve got but the Pi/OSMC does not seam to like it . I cant see the Pi’s file system over the network as I used to with XBMC but that is another problem. This new camera did not display on XBMC but I found that the SD card had been corrupted so I started again with a new SD card.
If I put this url straight in to OSMC as a video source I get the message that it can’t connect to the network server!

To see the Pi’s file system you have to install Samba from the OSMC store if you are on a Windows Computer.

I don’t use Ispy, but finding the correct rtsp url for a specific camera model can be tricky, I used VLC to test the url, and when it worked there, it worked in OSMC/Kodi.

You used to have to buy MPEG & VCL licences separately for the Pi, Is this still the case with OSMC even though I’m trying to look at a H.264 stream and hardware decoding of H.264 is built into the chip on the Pi?

For MPEG & VC1 that is still the case. H.264 should work without the licence codec. So first I suggest to check that your camera stream is H.264

So that indicates it is not codec related but network related.
Suggest you provide debug enabled logs and a few more information about your network setup.

I don’t honestly think its network related as I can get the pictures on a windows 10 desktop and the camera is supposed to be able to handle up to 10 clients.

I’ve set up some over clocking on this 2013 Pi model B and now get a flash of picture occasionally



Now if I click on the .strm file I get a flash of the picture about every 12-15 seconds and a grey screen in between but only if I also tap the fast forward button a couple of times. All very strange, With the previous camera I got a picture with XMBC out of the box once I got the .strm file right.

I’ve also tried adjusting the cameras settings

  • reducing the cameras video frequency from 60Hz to 50Hz
  • reducing the bit rate
  • reducing the resolution
  • reducing the frame rate
  • and changing the ‘image quality’

in all cases I still get this flic on/off image every few seconds and it does not matter weather the camera is hard wired to the router or the data is coming over a wireless connection.

Any other ideas would be welcome.