Virgin media - cant connect to

Ok so like the title suggests, im on virgin media and it appears that I am unable to connect to

Which obviously makes updating a bit tricky as under:


The osmc source is

deb jessie main

Ok so this had been a problem for me for a while but I hadnt really investigated what was happening as the rest of the update system was working. But I had disabled updating for the last couple of months as I kept on getting an error and when I ran it manually would get

500 Internal server error

When it tried to connect to OSMC.

Today I tried to connect to in my browser and was greeted with the same error.
Trying to connect to that site on my phone I can connect on 4g but not wifi, so its clearly a virgin media problem, could it be some sort of dns issue do you think?

Anyway manually changing the /etc/apt/sources.list entry to the following:

deb Index of /osmc/osmc/apt jessie main

Allows me to update successfully. And when i try httpS:// in a browser it does work, with a message about the site being insecure.

Is the osmc source likely to change from Index of /osmc/osmc/apt frequenlty?

I tried changing the source to

deb jessie main

But got the message

E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?

So of Index of /osmc/osmc/apt is never likely to change ill just use that.

You have a network issue.

It works fine on VM here
Eventually the FAU mirror will change, so you should probably fix your network problem

What IP address does resolve to? VM has a content filtering scheme that has been known to be a little too conservative. Is there a difference between the IP addresses returned by:




Tried both commands and they both resolve to which doesnt work if i try it in my browser.

If it works with HTTPS but not HTTP (we’re not set up for HTTPS on APT yet, but should still redirect if you ignore warning) then you likely have a transparent proxy somewhere causing issues.

sam@sam-XPS-15-9550:~$ traceroute
traceroute to (, 30 hops max, 60 byte packets
 1 (  1.105 ms  1.232 ms  1.231 ms
 2 (  10.506 ms  9.532 ms  10.659 ms
 3 (  10.813 ms  10.812 ms  10.979 ms
 4  * * *
 5 (  17.285 ms  18.232 ms  18.412 ms
 6 (  24.161 ms  17.472 ms  18.745 ms
 7 (  19.686 ms  19.848 ms  19.832 ms
 8 (  26.195 ms  25.285 ms *

Can you access the OSMC website OK? It’s served from the same IP as the APT mirror director. Does work for you?

Please provide a traceroute.

Yeah I can access ok but not

Again https and not http.

traceroute to (, 30 hops max, 38 byte packets
1 ( 11.520 ms 8.628 ms 8.625 ms
2 ( 9.837 ms 8.737 ms 9.887 ms
3 * * *
4 * * *
5 * * *
6 * * *
7 * * *
8 * * *
9 ( 22.321 ms 19.124 ms 19.411 ms
10 ( 29.974 ms 29.523 ms 54.594 ms
11 ( 28.844 ms 28.051 ms 33.881 ms
12 ( 27.995 ms 26.210 ms 25.866 ms

I have this same problem. Also using Virgin Media.

osmc@osmc:~$ traceroute
traceroute to (, 30 hops max, 38 byte packets
1 ( 1.998 ms 1.559 ms 1.406 ms
2 ( 10.509 ms 12.902 ms 7.788 ms
3 ( 10.091 ms 9.258 ms 11.102 ms
4 * * *
5 ( 12.047 ms 14.581 ms 9.387 ms
6 ( 16.719 ms 15.593 ms 18.910 ms
7 ( 18.263 ms 22.458 ms 20.237 ms
8 ( 16.945 ms 16.811 ms 15.777 ms

Virgin Media really are the pits. There’s no excuse for this kind of nonsense. It’s easy to say “network issues” but trying to get Virgin to do anything about it is likely to be a fool’s errand. And that’s discounting the possibility that it’s a deliberate block, which might not be the case.

I see that and both redirect to Index of /osmc/osmc/apt in the browser. Can you see the address in the browser?

Perhaps Sam might consider publishing a list of the mirror URLs. If we find them all being blocked then we know it’s not an accident.


I’m on virginmedia and having no issues. Will see if i can reproduce this evening, at work now.

Thanks Tom.

Yeah the ftp Index of /osmc/osmc/apt works fine so its some issue with the redirect I think.

Started having issues on other sites with the secure layer just refusing to work through virgin media so I’m reasonably certain its entirely to do with a proxy or something on virgin.

I just manually changed my apt get sources as it’s unlikely virgin are ever going to fix this.

Virgin do seem to have a bit of a reputation for networking snafus, as well as monkeying around with traffic.

I’m curious if you can access (without the s). It should change itself to https automatically, but that’s assuming you get through in the first place.

Working fine for me on Virgin here. Pretty sure this is a localised issue.

Let me know if it crops up again

Yes, I can connect to that address in the browser.

To get updates to work, I’ve had to apply the same workaround as @henryjfry, i.e. I’ve edited /etc/apt/sources.list

#deb jessie main
deb jessie main

No, I can only access the website if I type https. No redirect happens if I type only http.

It sounds like you have a transparent HTTP proxy.

wget --server-response -O /dev/null
--2017-05-09 15:35:06--
Resolving (
Connecting to (||:80... connected.
HTTP request sent, awaiting response... 
  HTTP/1.0 302 Moved Temporarily
  Date: Tue, 09 May 2017 14:33:14 GMT
  Server: Varnish
  X-Varnish: 106356727
  Content-Length: 0
  X-Cache: MISS from localhost
  X-Cache-Lookup: MISS from localhost:3128
  Via: 1.0 localhost (squid/3.1.19)
  Connection: keep-alive
Location: [following]
--2017-05-09 15:35:06--
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 
  HTTP/1.1 200 OK
  Server: nginx/1.10.2
  Date: Tue, 09 May 2017 14:33:14 GMT
  Content-Type: text/html; charset=utf-8
  Transfer-Encoding: chunked
  Connection: keep-alive
  cache-control: public, max-age=0
  etag: W/"1be87-91E/525gGnDdM6k5TtCmXw"
  vary: Accept-Encoding
  Age: 191
  Accept-Ranges: bytes
Length: unspecified [text/html]
Saving to: ‘/dev/null’

/dev/null               [ <=>                ] 111.63K  --.-KB/s    in 0.04s   

2017-05-09 15:35:06 (2.66 MB/s) - ‘/dev/null’ saved [114311]

Thanks for that useful snippet of info. It looks like the whole of the domain is being blocked by Virgin, not only the third-level domains like apt and download.

Since https encrypted packets are getting through to IP address, it appears that it’s not being blocked at the IP address level, since that address is very probably using shared-IP hosting and blocking it would also affect many other sites. It also means that they need to inspect each packet to see if it’s being sent to, which they can’t do with https traffic.

Sam needs to get on the phone to one of Virgin’s highly-trained helpdesk staff, who will no doubt tell him to switch his PC off and on, or ask for the serial number of his router. Get to it, Sam! :wink:

Not always transparent enough, it seems. And only for some Virgin customers.

Hi Sam, @henryjfry & @jenkar

It seems there may be issue with virgin media

Through osmc, all to devices on my network are showing the same (Except my pi connecting to pia vpn):

osmc@osmc:~$ traceroute
traceroute to (, 30 hops max, 38 byte packets
 1  RT-N66U-3FD0 (  4.416 ms  2.495 ms  1.601 ms
 2  *  *  *
 3 (  10.157 ms  11.759 ms  10.095 ms
 4  *  *  *
 5  *  *  *
 6 (  17.020 ms  15.239 ms  17.394 ms
 7 (  22.414 ms  23.808 ms  22.155 ms
 8 (  23.795 ms  22.488 ms  23.182 ms
 9 (  23.785 ms  23.943 ms  21.515 ms  

vpn pi client:

pi@raspberrypi:~ $ traceroute
traceroute to (, 30 hops max, 60 byte packets
 1 (  15.781 ms  15.377 ms  15.133 ms
 2 (  18.019 ms (  16.413 ms  17.189 ms
 3 (  21.686 ms (  22.100 ms (  21.343 ms
 4 (  26.260 ms  26.040 ms  25.850 ms
 5 (  26.904 ms  26.722 ms  26.232 ms
 6 (  25.824 ms  23.712 ms  23.358 ms

The vpn client on my network is the only device on my network which isn’t showing timeouts when running traceroute.

Although at the moment I having no issues updating my osmc, its good to know I can update sources.list with above advised fixed. I may just change it anyway to future proof it.

Thanks Tom.

That’s the (opposite) of future proofing, as that mirror URL
will likely change in the future; which is why we recommend using
the mirror director.


Ok cheers

Thanks Tom.