VLAN support in ConnMan

I have reluctantly decided to abandon OSMC, the reason being ConnMan’s lack of support for tagged Vlans, unless someone can advise me otherwise.

I have seen an old discussion about the need for 802.1Q tagging but my perspective is that they are a necessary part of a modern network – especially now in the current situation of increasing home working. To illustrate this point I explain my setup.

I have a SOHO setup, with one physical network cable between nodes acting as a trunk. This carries three vlans, one for business, one for family and one for business guests. It is accompanied by three BSSIDs. I would like the media centre to be accessible to family but not other users. Similarly I would like the business network accessible only to me and my associate and the internet accessible by all.

I had been using libreelec as my media centre for this including VAL functionality but having purchased a media centre HAT for my PI I switched to OSMC, it seeming to be the mainline choice for such. So I need to reconsider. If ConnMan get “fixed” I’ll reconsider.

Suggestions/Comments welcome.

Why do you need tagging? If the Pi doesn’t has any other function than the mediacenter you only would need to tag that port on the switch no need for tagging on the Pi unless you also run services for your business there.


Isn’t libreelec also using connman? Based on this thread I assume you could use the same commands on OSMC.

Thats a good point, but in this case i would need to purchase purchase another vlan aware switch, the current one is dumb. Maybe that’s the best option for now, but my view is that VLAN support is something that should be there.

Both OSMC and LibreELEC use ConnMan, so VLAN support should be the same regardless of distribution you are using.

Well most likely it is there (see second post) did you try it?

I was tinkering around doing various Vlan tests on other tech, so my recollection, which could be wrong is, that I specified the Vlan in /etc/network/interfaces. I certainly don’t recall using connman.

I’ll reinstall libreelec and post back results.

Thanks your comments.

Why don’t you not just try /sbin/vconfig add eth0 30 as written in the thread?
After sudo apt-get install vlan

LibreELEC doesn’t use /etc/network/interfaces. It uses ConnMan. Same for OSMC.