VLC External Player

Hello, I’m trying to set up my kodi (osmc) and I’m not succeeding at what I want, I would be very grateful if someone would help me. First of all I would like to be able to pause, rewind and streamline my m3u list (what I could do in an iptv player of xbox one and vlc in android), as I could not do in kodi I thought of using vlc along with osmc + kodi, I tried to add the file _/usr/share/kodi/userdata/playercorefactory.xml, but I did not succeed again, I will be very happy if anyone has a solution. Thks…

If you need VLC then Raspbian may be a better option

Thanks for the suggestion, actually I thought of using vlc just to pause, to advance, to use the timeshift in the mp4 videos uploaded by my m3u list, is there any way to use a player with these features in osmc?


OSMC does not have X Windows installed, and most video applications (like VNC) need X. You may want to ask on the Kodi forums if there is a way to do what you are looking for.

i’ve installed chromium via [Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch which

installs Xserver, LXDE core, Chromium,…a starting/launcher addon for kodi.

and it works great, altho it does exit kodi, which is restarted on logout from x…i had installed the repo vlc, but w/o h/w accel it’s useless:-(

i’ve been trying to compile w/accel using

Tutorial: Compile VLC with HW acceleration - Stretch, RPi 2/3 - Raspberry Pi Forums


How to compile VLC media player with hardware acceleration for the Raspberry Pi - The Pi

but of course osmc is not raspian, so i’m getting dependency issues:

Preparing to unpack …/liblirc-dev_0.9.4c-9_armhf.deb …
Unpacking liblirc-dev:armhf (0.9.4c-9) …
dpkg: error processing archive /var/cache/apt/archives/liblirc-dev_0.9.4c-9_armhf.deb (–unpack):
trying to overwrite ‘/usr/include/lirc/lirc_client.h’, which is also in package armv7-lirc-osmc 0.9.0-6

anybody know the fix?

You don’t need the LIRC development packages

OSMC provides its own version.
apt-get install armv6/armv7-lirc-dev-osmc will do the trick


thanx, sam, but

E: Unable to locate package armv7-lirc-dev-osmc

problem is version: liblirc-dev:armhf (0.9.4c-9) vs armv7-lirc-osmc 0.9.0-6

i’ll try removing the osmc lirc & see what works/breaks;-}


osmc@osmc-fios:~$ sudo apt-get remove armv7-lirc-osmc
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages will be REMOVED:
armv7-eventlircd-osmc armv7-lirc-osmc armv7-remote-osmc rbp2-device-osmc
0 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
After this operation, 3763 kB disk space will be freed.
Do you want to continue? [Y/n] y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database … 68195 files and directories currently installed.)
Removing rbp2-device-osmc (1.4.9) …
WARNING: You have tried to remove a package that is essential to OSMC’s operation.
To undo these changes, run ‘sudo apt-get -f install’.
dpkg: error processing package rbp2-device-osmc (–remove):
subprocess installed pre-removal script returned error exit status 1
dpkg: armv7-lirc-osmc: dependency problems, but removing anyway as you requested:
armv7-remote-osmc depends on armv7-lirc-osmc.
armv7-eventlircd-osmc depends on armv7-lirc-osmc.
Removing armv7-lirc-osmc (0.9.0-6) …
dpkg: armv7-remote-osmc: dependency problems, but removing anyway as you requested:
rbp2-device-osmc depends on armv7-remote-osmc.
Removing armv7-remote-osmc (1.2.2) …
Removing ‘diversion of /etc/lirc/lircd.conf to /etc/lirc/lircd.conf.distributed by armv7-remote-osmc’
Removing armv7-eventlircd-osmc (1.3.0) …
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

won’t try that again;-)

You’ve just bricked your system and will need to reinstall.

You can install VLC when you install this x11 desktop on OSMC


To undo these changes, run ‘sudo apt-get -f install’.

worked fine

You can install VLC when you install this x11 desktop on OSMC

already did that, vlc has to be compiled w/ h/w accel