VNC on Vero 2


#1

Hello,
I found this on GitHub:


Is it reliable and functioning?
I’d like to install it on my Vero 2 and control it via my desktop PC.
How can I do it? Via command line?

Thank you :slight_smile:


#2

Can you please enlighten me why you need VNC? “Control” the vero2. Control what? Run Kodi in VNC? Never had good experience with VNC. It works for some lightweight graphic stuff but don’t expect anything more.


#3

I’d like to view the Kodi menus of my Vero 2 from a PC and perform some commands as Refresh video library or backup Kodi configuration, etc.
But I don’t know if it is possible.
I’d like to have the graphic interface of my Vero 2 in my PC, but with the TV switched off.
Do you know if there is a way to do this?


#4

I do the same thing on my Pi that’s built into an amplifier - no screen at all.

You should be able to download, compile and just run the resulting vncserver binary


#5

There is a web interface to Kodi that you can use (via your browser). It needs to be enabled first. I’m on the Esturary skin and it’s in System > Service Settings > Control > Allow remote control via HTTP. Use the Chorus2 interface. You’ll probably also need to enable Application control. Here’s an article on Chorus2.


#6

I didn’t know Chorus2, very interesting!
I’ll try to compile and run the vnc server too.
Thank you very much! :+1:

edit: I’m not an expert in Linux, how can I compile and run vnc-vero2 via command line?
Wich packages I have to install? There are no instruction in the readme file…


#7

Have a look at texturecache.py
I use it for scanning library, changing settings etc…


#8

Thanks!


#9

Call me old fashioned but I’m a CLI-guy. My motto: GUI’s are for sissies, real men don’t use mice :smile:


#10

how can it be that there already is a working vnc for vero4k but none for the vero2?


#11

That VNC server should work on Vero 2. It just needs compiling.

Sam


#12

hmm it was what we were trying before … apparantly it compiled but then, on execution we got a segmentation fault (https://discourse.osmc.tv/t/vnc/17850).


#13

Probably worth a recompile. There’s been a few fixes since then.


#14

still the same:

osmc@B2VERO:~/vnc$ cd vnc-vero2/
osmc@B2VERO:~/vnc/vnc-vero2$ ls
bgra2rgb565_neon.h framebuffer.c newinput.c screenFormat.h
bgra2rgb565_neon.S framebuffer.h newinput.h updateScreen.c
common.h Makefile README.md vncserver.c
osmc@B2VERO:~/vnc/vnc-vero2$ sudo make
cc -Wall -std=c11 -mfpu=neon -o aml-vnc bgra2rgb565_neon.S framebuffer.c newinput.c vncserver.c -lvncserver -lpng -ljpeg -lpthread -lssl -lcrypto -lz -lresolv
framebuffer.c: In function ‘roundUpToPageSize’:
framebuffer.c:50:2: warning: implicit declaration of function ‘getpagesize’ [-Wimplicit-function-declaration]
return (x + (getpagesize()-1)) & ~(getpagesize()-1);
^
osmc@B2VERO:~/vnc/vnc-vero2$ ls
aml-vnc common.h Makefile README.md vncserver.c
bgra2rgb565_neon.h framebuffer.c newinput.c screenFormat.h
bgra2rgb565_neon.S framebuffer.h newinput.h updateScreen.c
osmc@B2VERO:~/vnc/vnc-vero2$ ./aml-vnc
Initializing grabber method…
–Initializing framebuffer access method–
line_length=7680 xres=1920, yres=1080, xresv=1920, yresv=2160, xoffs=0, yoffs=0, bpp=32
Initializing virtual keyboard…
open /dev/uinput returned 5.
First write returned 1116.
ioctl UI_DEV_CREATE returned 0.
Initializing VNC server:
width: 960
height: 540
bpp: 16
port: 5900
Colourmap_rgba=11:5:0 length=5:6:5
26/09/2017 19:15:53 Listening for VNC connections on TCP port 5900
26/09/2017 19:15:53 Listening for VNC connections on TCP6 port 5900
26/09/2017 19:15:57 Got connection from client 192.168.3.8
26/09/2017 19:15:57 other clients:
26/09/2017 19:15:57 Normal socket connection
Speicherzugriffsfehler


#15

Try building https://github.com/samnazarko/vnc-vero3 instead.


#16

ok nice, this version seems to work perfectly. thx for the hint!

cheers bendsch


#17

on debian stretch this version does not seem to work anymore. any ideas?
cheers bendsch

stops at this point:

osmc@B2VERO:~/vnc/vnc-vero3$ sudo ./aml-vnc

Initializing grabber method…
–Initializing framebuffer access method–


#18

Why do you run it with sudo?
For me it still works (on Vero4k)


#19

tried both, does not make a difference …

on vero2 it does not.


#20

It may need recompile onStretch