VNSI: Connection/Fetching channels takes ages


this is no new problem, in fact I have been ignoring it for many months:

When the VNSI-Connection to my VDR server is lost, it takes several minutes (eight minutes in this case) until it is running again (meaning: I can start a TV channel). In the meantime, I see “Channel symbols are searched” and “PVR-Manager is starting” flashing in the upper right corner.

Now I activated debug logging and restartet OSMC:

I have the same problem with my Raspberry Pi (2b, I think…) and my vero 2. The logfile is from the vero 2

The VDR runs on a haswell server with Debian Lenny, connected with 1GBit Ethernet. The connection itself is without a flaw, I can copy movies in seconds.

I hope you can help me spot this really annoying problem

Got the same problem with “PVR-Manager is starting” and loading channels for ages since version 2017-08. A fresh install of 2017-07 solved the problem for me.


Thanks, tomtom, for your information.

I hope that there is a better solution, though. I hate reinstalling :frowning:

Today, I saw that my libreelec fetched all the VNSI-data in less than a second. So it really seems to be a osmc-issue and not on the server side.

That is old! Haswell came out in 2013 or so; but Lenny is 2009 era.
You might find some benefits from updating VDR


Ups, did I say Lenny? I meant jessie :blush: and I’ll update to current stable as soon as I have the time for it.

As to haswell: I don’t tend to throw away hardware that’s working like a charm.

Besides: It has nothing to do with the topic. Since all is fine with libreelec and the problem occurs with oscm on raspberry and vero2, it’s unlikely that the server is the problem.

Is the binary addon and Kodi version the same?

How can I detect that?

Until now, I had vdr-plugin-vnsiserver version 1.3.1 on the server.
vdr vnsi client on kodi days it has version 2.6.23 which doesn’t match at all.
The newest version on githup of vdr-plugin-vnsiserver is 1.5.2. I installed that right now, but it doesn’t improve the long connection time.

I added my debug log (see first post), there you can see some vnsi version numbers

Thanks for your help!


Just out of curiosity I went to Kodi->Settings->PVR&TV-> Menu/OSD and “clicked” on “Search for missing Channel symbols” (my translation from German UI). That itself takes several minutes. Is there a reason that it is so slow? Can I speed that up somehow?


Not that I’m aware of.
If it occurs with Pi and Vero I would check the backend.

The VDR guys will know more than we will for sure.
Please keep us posted.


I can hardly believe it, but removing the channel icons lowered the time to connect to something more reasonable… (still not really fast, but bearable).

I would check with the VDR guys. They will know a lot more than us.