VobSub subtitles not shown

HI, I’ve got a new Vero 4K+ and I’ve got an issue with mkv file with VobSub subtitles. Kodi properly selects the language, populates the Subtitles menu in OSD, but the subtitles are never shown. Switching to other language or disabling/enabling does not help. All other types of subtitles (external, text embedded in mkv) work properly. I’ve verified that the subtitles are present in the file by playing it using mpv on my computer.

Here’s the log: http://paste.osmc.io/uqefatudor.vhdl (I’ve only redacted MAC and IP addresses).
And here’s the mediainfo ofthe file: http://paste.osmc.io/izazoficuk.coffee

I think I do not have any other file/release with VobSub subtitles, so cannot check if the subtitles work there (and haven’t found a test file in Samples), but will try to find something and test with a different file.

I’d be grateful for any help!

As far as I know.sub is dependent on the .idx file to work.
.sub contains the image of the subtitle and .idx the time stamp to tell the player when to display wich picture from the .sub

Thanks @k2u3, but I think this was not the problem. The subtitles were embedded in the mkv file, so I believe this was done properly. I’ve verified the video with playing it with mpv and it worked. I’ve also extracted the subtitles using mkvextract and it properly created .sub and .idx files (this did not help and OSMC was not able to show the subtitles though).

Oh I’m sorry to hear that. I never had that problem before and I watched plenty of movies with .sub and .idx subs on my 4k I hope you’ll get some proper help soon.

1 Like

I think this is an upstream Kodi issue: https://trac.kodi.tv/ticket/17681

Sam

I have the same issue with a Vero 4K+. All updates installed.

Also with subtitles in an mkv (created with Handbrake).

The subtitles are selectable and display fine with VLC on a PC.

Kodi reports that the internal subtitles are there, but there is no way to move the cursor down to select them or flip any switches.

I’m not sure the issue @sam_nazarko linked above is the same since they describe an issue with skipping, which works fine.

Is it possible to get some sample files?

Sam

Three sample files. Two from a DVD, encoded as m4v and mkv. Third from a Blu-Ray encoded as mkv:

For all three, the subtitle (English) can be turned on in VLC in Windows.

4K+ says “Local subtitle found” but there is no option to turn it on. Screenshot:

You need to select the subtitle under the sound icon.
The option you are selecting is to look for subtitles via an online service such as Open Subtitles.

Sam

That’s it! Subtitles all work fine. Should have looked in every icon! I had another Kodi box and the native subtitles were accessed from that subtitle icon, which is what threw me. Thank you @sam_nazarko

2 Likes

Hi @sam_nazarko,
I believe this was not the problem in my case. The subtitle stream was automatically selected based on my language settings, the subtitles were not shown even when I selected other subtitle streams in the Subtitle menu/button (Audio menu/button only lists audio streams). I found another mkv files with VobSub subtitles and they work properly. You can find sample files here https://ufile.io/jhsjg and here https://ufile.io/mr5fp — the only difference is that the not working file has multiple subtitle streams — maybe that is the cause?

Also, please find the attached screenshot showing that the subtitles are properly selected (the video was not captured properly in the screenshot, but it played without a glitch).

I am using Eminence 2.0 skin, but I also tried the default one and enabled the subtitles under the audio icon.

Can you post a debug log?

Hi @sam_nazarko, sure, here’s the log http://paste.osmc.io/efecucikot.hs (I just removed Kodi Old Log, since the file was too big and not properly processed by the paste service — in the first post you can find the debug log when playing the original file, not the sample — this log contains Kodi Old Log).

Hi, any ideas what it might be? Should I create an upstream bug ticket?

I think it may be a Kodi issue.

Sam

This looks like a bad rip issue, not a Kodi bug. The sample provided did not have working subs in any other player I tested it with. I tried remuxing the file but that did not make the subs work. Oddly enough the sub and idx files were intact enough that I could get an online converter to spit out a working srt so the information is actually there. I think fixing a bad sub rip is a bit out of scope for this forum though.