Volume Amplification When using OMXplayer does not work.When OMX disabled 1080 videos shatter


On latest update of OSMC the system runs great, faster in my opinion or at least kodi is more responsive.

I have bought a long time ago an mpeg licence for the rpi2 i am mainly using.

The only draw back is that sound in general (both hdmi and analog since i am using both of them), is quite low. So i end up trying the volume amplification and it does not work if i am using omx player.

If i disable omx player then volume amplification does indeed works but i get choppyness/shattering when i am playing something that is full hd.

Don’t know why or if there is something i can do on my end.
If you need logs please advice the situations you need the logs from. With omx enabled? Disabled? Enabled andvolume amplification on +something? Disabled while playing a fullhd media?

Other than that i get no problems at all. Samba works as it should with the right tweaks on it. And everything is smooth as butter. Hell even kodi seems to load faster.

I also have to say that volume is not exactly low. I have to use the tv volume almost to 60% to be able to hear but the funny part is that while most sounds are fine there there are frequencys that are very loud. Like some frequensy are playing lower than others.

I do not use 5.1 audio system or something. Just stereo sound. I do not overclock.

Thanks in advance.

Try enabling boost center channel if you are playing 5.1 content on a 2 channel system

i have but the problem is still there.Exactly the same problem with media that have only stereo sound.

Does not matter if boost center channel is on 0 or +6 or 12, gennerally sound is low but some frequency’s are loud.Quite weird.

I did a test with alsa to see what is going on and sound is back to normal, omx enabled or disabled. Volume amlification works with omx enabled or disabled.

Ofcourse that is a no joy for me since i found no way to output audio at hdmi and analog at the same time.

By the way @sam_nazarko to you and all the team behind, i would like to express my gratitude.

up to january update the analog audio had a hissing static sound produced on the speakers when nothing was playing.
After that update you fixed something that removed that sound but introduced this problem.

Is it something i can revert? I prefer to have the static hissing sound on my analog speakers when nothing is playing than what i have now.

Omxplayer can’t use volume amplification. Only mmal. It’s a pity cause omxplayer is much better than mmal currently.

In Krypton video player is getting worked upon so should be much smoother.

For smooth mmal playback, do you have “adjust display refresh rate to match video” and “sync playback to display” both enabled?

Omxplayer could use volume amplification up to some months ago. What exactly changed?

–amp n set initial amplification in millibels (default 0)

Did @popcornmix disabled this and if so why?

Adjust refresh rate and sync playback are enabled both.
The video hick up are there tho and only in 1080 videos