Volume at maximum after reboot

Hi all,

This is puzzling me for a while. Everytime a reboot the system, volume jumps up to 100pct. I always have to manual switch it back to a more normal volume. How can I change this?

I’ve a rather funny setup. My osmc runs on a raspberryPi 3 with an X6000 card mounted on it to be able to distribute audio to a channel 4.0 setup.
I guess something goes wrong there.

I also have squeezelite running in the background. But the volume misery already existed before squeezelite.

Maybe this can helps, i also can’t change the volume with my remote control (samsung). That’s the only thing that doesn’t work from the remote.

Here’s the log:

Follow the instructions on creating an autoexec service in Kodi by following the instructions in their wiki here…


for the autoexec.py you can use…

import xbmc


and you would replace the “75” with whatever percentage you wanted the volume to get set to on startup. Also note that once you create the files you will need to reboot Kodi in order for you to be able to enable the add-on.

As for your remote not controlling volume, that is probably because your using CEC and your TV is not sending those commands to Kodi. This is what normally happens as your TV expects that it should be controlling the volume unless it sees an amplifier on the CEC bus. Since your sound system is not connected that way your TV has no way of knowing and changing its behavior.

Hi darwindesign,

Thanks for your feedback. I’ve installed that selfmade addon, but still, volume pushes to the maximum.
I’m pretty sure I’ve installed it correctly.

Here’s my log: paste.kodi.tv/bocirufeva

I’m not sure exactly what is going on. I know what I posted works as I tested it right before I typed that out. Maybe you could try ssh’ing into your RPi and enter the following at the terminal…

kodi-send -a "SetVolume(75,showvolumebar)"

As soon as you hit enter you should see the volume icon popup on the screen and the volume should be set to 75%. If that is working then double check your autoexec.py to make sure it is exactly as I posted above. In particular, if you did not copy/paste the text maybe make sure you didn’t confuse the back quote (grave, left quote, whatever you want to call it) with an apostrophe which is what those tick marks need to be.

Hi darwindesign,

Yes the suggested code works perfectly on ssh (i also see the bar soundbar on the screen). I’ve also no idea what is going wrong. But some process must trigger the volume to its maximum, but I can’t find it out which one it is.

Kodi didn’t use to, but it does currently, I have no clue why. I assume it to be an intentional thing as a more common complaint is along the line of Kodi’s volume getting reduced and then someone can’t fix it with a remote as they are using CEC.

Regardless of the why, since your system worked correctly sending the action via the terminal then I can only think that there must be something you missed in the instructions, or a typo, when setting the autorun up. All I did to get it working was follow the directions from the wiki and used one of their examples listed for the python script just with a swapped out Kodi action.

I would offer up a different/simpler solution if I had one, but I don’t know that one exists. When you go searching the web the only thing your likely to run across is inserting the volume setting in an advancedsetting.xml but that solution has never worked.

Maybe this new info could work. I now changed the hardware to a pi4 but the problem presist.
The solution you offered did work in the end but the volume jumps up again after the default I’ve entered, by this being at 100pct after the reboot.
I guess there is no other solution, but I thought it may be of interest that the change of hardware did not have any affect

Are you using profiles? I think there is a flaw which the autorun when using something other than master profile. If you reboot and your using settings such that it just loads the last profile that was logged in the autorun script doesn’t actually run. If you log out and then back in then it runs at that point.

Try this. Install alsa-utils:

sudo apt-get update
sudo apt-get install alsa-utils

Then run alsamixer and adjust the volume for ‘PCM’ to what you want, with Kodi’s volume at max.

That setting should survive a reboot.

This is going to cap the max volume though isn’t it? I think the OP is looking to have a regular listening volume at boot with the ability to still adjust it up beyond that.

Good point, well made.

Hi grahamh,

If this solution prevents me from blowing up my speakers every time after a reboot, that’s also already a fine work around. let’s see if i can make that work