VPN guide please

Hi all, while I’ve found a few threads on VPN setup, including ones saying that it’s now built into OSMC I still can’t work out how to add VPN to my Vero 4k connection.

I’d be very surprised if I’m the only one wanting to use a vpn on my box, but as there isn’t a FAQ guide I assume that this isn’t a working feature for OSMC at the moment?

Has anyone been able to set this up successfully, and if so would you be kind enough to walk me through the process please?

I’m using PIA if that helps.

Thanks,
Andy

You can install the Brian Hornsby VPN addon. Things should then work out of the box

Sam

https://www.backtrails.net/2017/04/30/openvpn-setup-for-private-internet-access-pia-vpn-raspberry-pi-3-osmc/

You will need to be familiar with command line though:

https://osmc.tv/wiki/general/accessing-the-command-line/

Thanks Tom.

I am using Zomboided VPN manager It works great with a lot of VPN providers.

Simply run these commands

sudo apt-get update
sudo apt-get install openvpn * Already installed
sudo apt-get install psmisc

After that install the VPN manager as described in the above link, and configure the VPN connection from the addon menu in OSMC.

OpenVPN is already included now.
I will add psmisc in the next update

1 Like

What internet streaming apps are available through Kodi / OSMC that would benefit from a VPN’s location switching capability?

We don’t explicitly discuss the bypassing of Geo-restrictions on this forum. Thanks.

While geo-restriction bypassing was never asked for explicitly, allow me to rephrase. What add-ons are available for Kodi that would even require geo-location? I wasn’t aware Netflix, Amazon Prime or other streaming services had an Kodi add-on where you would have to login with your subscription credentials.

My message was to provide a warning that the subject will not be discussed further on this forum. This is clearly the direction your line of questioning is quickly moving toward. It’s also of topic for this thread. Please don’t attempt to press the point.

I think you’re reading too much into this, but I do agree it’s off-topic for this thread. I will start my own thread regarding streaming services and Kodi.

A simple example would be BBC iPlayer.
This is a legal add-on for TV license holders in the UK.

Getting around restrictions can be beneficial for Brits abroad; but the easiest way to do this is to run a private tunnel to your home connection.

Circumventing such a restriction isn’t necessary illegal. But it’s complex and not something we can advise on much.

my ISP seemingly throttles all streaming services so I choose to use a VPN to avoid this and enjoy higher quality streams.

Thanks for the advice, I feel really thick for not getting my head around this but I’ve installed the brian hornsby addon, downloaded and uploaded the config file but having read around I wonder if I need to edit the files. Can’t find a definitive guide on this, and some of the guides appear to be for raspberry pi rather than Vero 4k.

The link to the guide in this thread, thank you. I can login to vero but sudo apt-get update does nothing

Hi,

Could you please provide the output of the command. Screenshot or copy & paste?

Thanks Tom.

thank you, I thought this was going to work. It’s all installed, I can add the user name and password through OSMC.

Go through the wizard and it finally throws up “Error connecting to VPN, something unexpected happened. Click log for more information”

log then says inactivity timeout (-- ping-exit) exiting

Are you sure that your Vero are connected to the Internet?
If I disconnect my Vero from the Internet it comes up with inactivity timeout (-- ping-exit) exiting in the log as well.

sudo apt-get update should give you an output similar to this

osmc@osmc_stue:~$ sudo apt-get update
Ign:1 http://ftp.debian.org/debian stretch InRelease
Hit:3 http://ftp.debian.org/debian stretch-updates InRelease
Hit:4 http://security.debian.org stretch/updates InRelease
Get:5 http://ftp.debian.org/debian stretch Release [118 kB]
Hit:2 http://ftp.fau.de/osmc/osmc/apt stretch InRelease
Fetched 118 kB in 2s (57.5 kB/s)
Reading package lists... Done

Another thing, you seem to have tried both the brian hornsby addon and Zomboided Addon, did uninstall the other before you tried the next one? maybe something is conflicting when both are installed.

yeah I’m definitely on the internet I wouldn’t have been able to download the zip file from the repo without internet.

No idea why it can’t connect now :frowning:

Which log? The Hornsby log or the system journal?

I’d recommend you set openvpn “verbosity” level to 3 by including the line verb 3 in the openvpn config file. That should give us a better idea why it’s not connecting.