VPN Manager troubles

#1

I’m using VPN Manager from the Zomboid repository together with ProtonVPN

It all seems to work fine, I can export an OVPN file from my ProtonVPN account and import it into the manager, using the right OpenVPN login info etc. It seems to authorize and connect just fine, but then it’s stuck at “Connected, checking location info.”, which times out and it says I should probably check my DNS. There is a ‘possible DNS fix’ option in VPN Manager but that doesn’t help. Eventually, it’s not connected to the internet.

Logs: https://pastebin.com/2SWMW0Nj

#2

Some full debug logs via My OSMC may help, as they’ll provide further connection details.

Sam

#3

Strange, the usual method via My OSMC didn’t result in an URL, but I was able to generate a log with the grab-logs -A command:

https://paste.osmc.tv/osujulesed

#4

Have you checked the DNS in /etc/resolv.conf?

#5

I have now, it says (redacted the actual addresses):

# Generated by Connection Manager
search home 
nameserver xx.xx.xx.xx
nameserver xx.xx.xx.xx
nameserver xx.xx.xx.xx
#6

Are they correct?

#7

I’m not sure with what to compare them to, or what it should contain. I see a ‘remote’ address in the generated .ovpn with a bunch of different ports, but it’s a different IP from any of the ones in resolv.conf.

#8

Try changing it to 8.8.8.8
This will give you DNS leakage for temporarily, but it’s a good test

#9

Thanks, should I change all 3 addresses in resolv.conf to 8.8.8.8 or just one?

#10

Just have one single entry of 8.8.8.8

Cheers

Sam

1 Like
#11

That works! Awesome. How do I set it up properly without any DNS leaks? I already saw that it resets the resolv.conf to the old settings after a reboot I did previously.

#12

At a guess, this means that your provider is not supplying the correct DNS information

1 Like
#13

I’ve contacted ProtonVPN for the correct DNS address, and if anyone is interested, this is the command to prevent resolv.conf from being reset:

If you would like your resolv.conf to not be reset to default you can try this:

First, execute the following command in Terminal:
sudo chattr -i /etc/resolv.conf

Next edit the resolv.conf file with the IP address you mentioned with this command:
sudo nano /etc/resolv.conf

Afterward, execute the last command to prevent the resolv.conf from resetting to default:
sudo chattr +i /etc/resolv.conf

After performing these commands your resolv.conf should not revert to default after a reboot.

#14

You can configure manual DNS settings.
Making resolv.conf immutable is a bad idea and could cause system instability.

They should fix their DNS

#15

The DNS address is being passed through from the server just fine:

2019-06-10 17:11:12.849 T:3802129120  NOTICE: Mon Jun 10 17:02:43 2019 PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1,dhcp-option DNS 10.8.8.1,sndbuf 524288,rcvbuf 524288,explicit-exit-notify,comp-lzo no,route-gateway 10.8.1.1,topology subnet,ping 10,ping-restart 60,ifconfig 10.8.1.26 255.255.255.0,peer-id 24,cipher AES-256-GCM'

I did a few searches and IP address 10.8.8.1 seems to be the correct one for ProtonVPN. And being a private address, it’ll only be accessible via the VPN tunnel.

I’m guessing that the problem lies elsewhere.

#16

That is indeed the correct IP address. What is the best way to set this correctly?