VPN not working on Vero 4k+

Hi all,
I’ve been using the VPN manager for Open VPN on my Vero 4k+ for a long time (a year or so) and during this time, I did not update my Vero at all (I have manual updates and I just forgot). Few weeks back, I finaly updated to a newer build and the VPN stopped working (not the plugin, it connected succesfully). After some basic investigation, i found that the DNS was leaking. So I checked the extended info within the plugin and spotted a difefrence: the DNS was showing (or - not sure now as I’m at work and cannot check) instead of my tradtitional No matter what I did or set in the network configuration, it always showed this 127.0.x.x and the DNS was leaking.
So I wiped the whole thing and installed older build - same thing. I repeated several times, until I tried the oldest build I found - from January 2023 - and it was working as before! I tried to update again - and it broke the functionality again.
So now I’m stuck with the January 2023 build and cannot update. So what happend after this build? What has changed? Or am I doing something wrong?
I saw some posts about up and down scripts, but the description was too confusing and I did not manage to get it working even with this - maybe I set something wrong.
Any help would be appreciated.

Thanks @fzinken for very quick response. I’ll try it once I get back home and see if it works.
Have a great day!

Came back just to say it worked! Thanks a lot again.