Watching Purchased content on VERO

Once upon a time it was possible to watch content bought from google movies.
That was done using the youtube plugin for kodi.

Viewing purchased content was not a problem then. There was even a “purchased movies” folder allocated in the plugin so finding your content was easy.

I used to watch Spectre (The James Bond Movie) on a raspberry PI model 3. It played perfectly but after a few minutes warnings appeared that the PI was overheating. So I did not risk to watch the entire movie.

A few years ago I tried to watch some of the movies I bought from google when I first bought the VERO 4K + but it turned out not to be possible.

I now have limited success viewing movies I bought from google on the Vero 4K+ The movies load, but after a few seconds they seem to fall in a loop playing only the first 6 to 8 seconds or so of the movie. Identification is not the issue here. Perhaps it is a matter of settings.
I hope that this issue will some day be resolved so it will be possible again to watch purchased content from google on the VERO.

Here is the latest log.

We’ve discussed this before extensively.

You don’t own those movies. Google does.

OSMC is about self-control and not surrendering yourself to companies that sell cheap devices to lock you in to an ecosystem (Amazon Fire for example).

We are working on supporting DRM. But we will do so on our users terms, not Netflix, Google etc terms.

I remember reading this article as a teenager:

This is an apolitical forum, but make sure that whatever you want to own is owned physically or digitally on a device in your possession (and backed up).

We are working on supporting streaming services, and I believe we’ll get there. But keep in mind that companies like Google (or Amazon in above case) can change the rules at any time.


What I am saying is: We are almost there:

Videos that I purchased from google do load on the VERO 4K+ using the youtube plugin. But they keep looping in the first 6 to 8 seconds.

So, this means that I have been properly identified by google as a user that has the right to view certain content that I have purchased from them.

The VERO even downloaded the latest widevine so, DRM is most likely not the issue.

There may be some settings somewhere in kodi or in the youtube plugin that are not correct…

Watching videos from google with the youtube plugin has worked before, (even on a raspberry PI 3) .

I hope that we can figure out what the real problem is here, and how to resolve it.

1 Like

When was this?

My advice still stands, current Widevine on OSMC will be L3 but we are licensed for L1 on Vero V.

I got the raspberry PI 3 on January 29, 2018. So it must have been some time around that period.

Did you see anything in the logs of the VERO that can explain why a purchased movie keeps running around in circles?

Some time ago I was able to watch Dr No (also purchased from google) but there was no sound. Playback was more or less smooth.

The raspberry PI 3 was able to play purchased content from google videos back then in 2018 -2019. The only thing was that it had to work very hard to play such videos. And after a while of watching a video a warning appeared saying that the PI 3 is getting hot. So I did not dare to watch a complete 2 hours or longer of movies.

The youtube plugin in those days had a menu entry that said something like “Purchased movies”.
The current youtube plugin ( does not have such an entry.

On Vimeo I have a few movies that I bought there. I can watch them without any problem using the VERO 4K+. Crackle also gives no problems when you watch movies there.

I hope that it will be possible to watch purchased content from google using the VERO. As I said before, we are almost there.

A few months ago trying to view a purchased movie from google on the VERO 4K+ gave only an error message.

I hope that you will find information in the log that may help explain what is the real issue.

I suspect that Vimeo doesn’t use any content protection.

Widevine technology is always evolving and with each update when using L3 (which is software decoding) it becomes more computationally expensive, although I don’t believe your issue to be a CPU bound issue.

Widevine technology from five years ago isn’t comparable to Widevine technology today.

But I’m not sure this is necessarily a Widevine issue. You can certainly verify as such with other Widevine enabled streams.

From what I’ve read (quick Google) the YouTube movie purchases features is going and the plan is to move users to something called Google TV. I have no clue.

@anxdpanic is an OSMC developer and also the developer of the YouTube Kodi add-on. I’ll send him a link to this thread and see what he says to say.

I hope that this issue can be resolved. Vimeo does use encryption, I found this statement on their website:

“Vimeo OTT DRM uses a combination of the following DRM technologies in our apps and experiences: Apple Fairplay. Google Widevine Modular.”

Crackle also uses widevine. In various occasions the widevine component is updated automatically on the Vero when you try to watch content that they provide.

Some time ago there was an issue on crackle too. Videos ran for a minute or so and then freezed. After a widevine update that problem went away.

It seems that I am not the only one having problems with purchased google videos. I found this part of a conversation on the web:

"April 24 2020


I have latest Kodi version. Latest version of youtube addon (installed from zip). Lates version of adaptive inputstream addon.

API things is installed. I see youtube purchace folder and even see film I bought.

I try to start the video. Kodi thinks some time like it happens for free videos but… all things is stopped in ~ 5 sec.

Please look at logs below.

Yes i see

ERROR: GetDirectory - Error getting /usr/lib/kodi/addons/inputstream.adaptive/

I also noted that inputstream.adaptive in other directory btw (/storage/.kodi/addons/inputstream.adaptive)

I tried to create symbol link but /usr/lib/kodi/addons/inputstream.adaptive/ is read-only filesystem.

Oh… So many issues to get video I bougth at kodi :frowning:

Please advice. "

I hope that this problem with purchased google content can be resolved. Google videos is not going away. What I heard is that they want android users to use a new app (google tv) or go to youtube to buy videos.

I will checkout google tv later when I have a newer tablet. The one that I have now is too old, it runs android 5.1.1 Samsung does not send updates anymore for that model.

To rephrase – perhaps the content you are watching on Vimeo isn’t using DRM.

There are free movies on Vimeo, these are perhaps not encrypted. But content that is paid for is usually encrypted, and most of the time not offered for download. I am watching a movie that I bought there from an ancient civilization researcher. This one is encrypted. (True Legends, technology of the fallen is the title)
find the vimeo user called gensix productions. I know of another movie with the title “Sensei Redenshon” this one was made by filmmakers of Curacao and the Netherlands. This one is also for sale, and can only be streamed. Look for a vimeo user with the name yardvibes.

This is the text from a screenshot showing the information when you long press the information button on the VERO remote control. I thought this information may be helpful. This is what I see when I am playing back a purchased movie thru the youtube plugin.

Star Wars: The Rise of Skywalker (2020)

10:16 AM Ends at: 12:38 PM

A long time ago in a galaxy far, far away




Video decoder: inputstream.adaptive.h264.decoder (SW)

Pixel format: unknown

Deinterlace method: unknown

Video stream: 854x480p, 1.78 AR, 23.976 FPS

Audio stream: FL, FR, ff-aac, 32 bits, 44,100 Hz

00:00:05 / 02:21:49

The YouTube add-on developer says

I think it’s best to redirect him to the YouTube add-on Github, really Purchases never worked perfectly they use a proprietary blob (cant remember the name) to identify the resolution you paid for and its combined with one of the keys. So the add-on separates the two and best guesses resolution. playing the wrong resolution did stuff like he’s experiencing iirc

Is the developer referring to the youtube plugin, or has he something even newer? I installed the youtube plugin a few days ago. I can watch most youtube videos now on the VERO 4K+ using the youtube plugin. But The purchased google videos still give problems. They run only for a few seonds 5 or six seconds or so and then get stuck and keep repeating those first seconds in a loop. Some people in the forums that I read say it is because the player is using a Software decoder [Inputstream.adaptive.h264.decoder (SW)] in this case, instead of the hardware decoder. So it is using the CPU of the player instead of a more sophisticated GPU. Some people claim to have fixed this problem for ff-h264-d3d11va (HW) It seems that they found a solution for this problem:

KODI Forum

24 Mar 2018 — I’m running Kodi 17.6 (Arm64) on an iPad Air with iOS 11.1.1. For some unknown reason, some of my H.264 video files are decoded with ff-h264 …
Missing: d3dva11) ‎| Show results with: d3dva11)

Thanks for your response. I hope that someday we will have a solution