WD MyBook doesn't spin down

Hi Guys!

I’ve already spent hours looking for a solution, but came up with nothing. So I finally signed up here in hope of help.
I’m running OSMC on a RPi2. The SD Card only contains the OS, all my music and videos are on an external hdd. Yesterday I switched out my Toshiba HDD with 1.5 TB for a Western Digital My Book with 4 TB.
The Toshiba spun down after a while of idling. The WD keeps on spinning indefinitely and I don’t know why.

sudo hdparm -y /dev/sda makes it spin down like it should.
sudo hdparm -S 120 /dev/sda looks like it should work, but after 10 Minutes nothing happens, the drive keeps spinning. (I even set it to 30 seconds for testing purposes, but that did nothing either.)
Likewise, editing the hdparm.conf didn’t help.

All videos and mp3s contained on the drive are in the database and OSMC doesn’t look like it’s checking for new stuff, which would keep the hard drive active.

The drive isn’t mounted automatically, but with the following entry in fstab:
UUID=TheDrivesID# /mnt/usbstorage1 ntfs defaults,auto 0 0

I’m a complete novice when it comes to Linux in all forms, so please be patient with me (and give me detailed instructions).
I already tried all three methods outlined here: http://www.htpcguides.com/spin-down-and-manage-hard-drive-power-on-raspberry-pi/
All three look like they should work (no Error messages or anything), but don’t do anything in the end.
I don’t know what else to try and I’m kinda worried for the health of my brand new drive. :fearful:

Best regards,
Sanschan

Just a thought after googling abit, have you tried “sudo hdparm -B 1 /dev/sda” ?

Cut and pasted from man hdparm:

 -B          Get/set Advanced Power Management feature, if the drive
               supports it. A low value means aggressive power management and
               a high value means better performance.  Possible settings
               range from values 1 through 127 (which permit spin-down), and
               values 128 through 254 (which do not permit spin-down).  The
               highest degree of power management is attained with a setting
               of 1, and the highest I/O performance with a setting of 254.
               A value of 255 tells hdparm to disable Advanced Power
               Management altogether on the drive (not all drives support
               disabling it, but most do).

And, of course, this has to be set after each reset / power-up.

Ah, forgot to mention that: I tried -B already.
The reply I for your suggested command reads like this:
setting Advanced Power Management level to 0x01 (1)
HDIO_DRIVE_CMD failed: Input/output error
APM_level = not supported

So sadly, that’s not an option either.

Edit: At the moment, I’m solving the problem by shutting the Pi down whenever it’s not in use. That shuts down the hard drive as well.
But before changing hard drives I used it as a Media Server for my PC and Laptop as well (via Samba Server) and I’d like to do that again, so always powering down the Pi isn’t an option long term.
So my bonus question would be: What’s better for the hard drive short term? To let it keep spinning the whole day, even when it’s not in use or powering it (together with the Pi) up and down a few times a day?

I contacted Western Digital and asked if they could help me with the problem and whether it was better for the Drive to configure a spindown time or just leave it running.
They couldn’t help me with the configuring, but said that constant spinning puts less wear on the drive.
So I guess I’ll just leave it as is.