Weak bass output Vero 4k+

Usually I’m letting my Apple TV do all the streaming duties through Infuse/plex.
But I got a Vero4k+ for the times I need Atmos. ( PlexKodiConnect )

I’ve been noticing lately that movies that should have a great bass and dynamic soundtrack doesn’t sound right on the Vero. There is LFE output, but its weak. It almost seems like it’s a 30Hz high pass filter on or something. The deep bass is missing.

Both on my computer and the Apple TV the same soundtrack sounds like it should. The bass is strong and have full low-end extension.

I’ve been over the sound settings, HDMI passtrough is on ( AML-M8AUDIO, HDMI ). Output: Best match, tried both 5.1 and 7.1 etc

Am i missing something?

Can you upload a log so we can see your audio settings?
What is the make and model of your receiver?


I’m using a Lyngdorf MP50 processor.

Thanks for looking into this.

Audio settings look OK to me. How are you connected, is it like:

Vero > HDMI > MP50 > HDMI > TV?


Vero > HDMI > MP50 > HDMI >TV / Projector. ( TV = LG OLED55B6V, Projector = JVC DLA-X5900)

Does the MP50 have different settings for the LFE for each HDMI input?


It’s the same for all inputs/sources.

Since you have passthrough enabled, the Vero won’t be touching the audio. Can you try swapping the HDMI cable and port with one of the working devices?

EDIT: I did just notice one thing, but it should not be related. You have the Kodi GUI set to 2160P. It should be set at 1080P.

I can give that a try, but i’ve never heard of HDMI cables causing these types of problems.

I’m using these cables:


The file(s) you are testing with are the same files? Or are you using different ones?

Im using the same files when comparing

How are you doing that? The Vero 4K+ is sending Atmos, while the Apple TV is sending out whatever Plex is sending it, which is not Atmos.

So, the soundtracks are not the same. There’s no way to know if Plex is doing the right thing when converting the audio to a format the Apple TV can handle. It could be artificially boosting the bass. Or, it could be mixing bass from the regular channels into the LFE, while the Atmos doesn’t do that.

Do you have full range speakers in all positions?

Do you have transcoding in Plex turned off? And have you tried playing the file without using Plex?

Using Plex on Vero and Apple TV. Transcoding off. Also compared files that does not include Atmos. But Apple TV does indeed only LPCM and not passthrough.
The same soundtrack on MPC-HC from my computer sounds normal.

The speaker system is x-over at 80 Hz, everything below that is routed to LFE.

I’ll do some more testing tomorrow. Thanks for your time and input.

Yes it does. You need to RTFM…

Source Management
In the Source menu, you can register the individual sources connected to the MP-50 by the
audio and/or video input sockets they use.
Add Source
Source name
Input the name for the source.
Lipsync offset (ms)
Set delay time in milliseconds to ensure that the video and audio signals are played back
Volume offset (dB)
Enables you to match input levels from different sources.
Audio input
Select the audio input connector.
If you want the audio input to match the video input from an HDMI source,
select HDMI Audio.
Default postprocessing
Select the default postprocessing mode.
Default voicing
Select the default voicing

Of course you have a lot of options on a surround processor, my point was that all these settings are the same for all the sources when compairing. I’ve volum matched all the sources, and post processing and voicing are turned off.

Ok so I have been playing around a bit based of your suggestions and input, and It seems like the bass level is nerfed about 10db when playing a Dolby Atmos track !? So on the Vero when I change over from the Atmos track to the secondary non Atmos audio track, the bass level is normal.

Is this a thing with Dolby Atmos? Never heard about that.

I have a setting on my processor that lets me change the gains for each speaker channel when the input is DTS/DOLBY and Atmos.

So with 10db gain on the LFE channel, the bass on Atmos tracks are similar as on the Apple TV, and on audio tracks that is not including Atmos on the Vero.

The only problem now Is If I should play a non Atmos track on the Vero ( Dolby/Dts ), the bass will be 10db to hot.
Apple TV is not affected as the audio is LPCM.

So problem “solved” i guess.