WEB GUI and DLNA not working

Hi,

I successfully installed osmc on my old apple tv first gen and, despite the answer on this forum, also Sickrage and Couchpotato are working flawlessly. I need to uset is headless to download and share content via dnla.

I can ssh into my apple tv, I can see sickrage, transmission GUI, SMB is working well but when I try to connect to the GUI: osmc:8080 or 192.168.1.4:8080 I can’t access the GUI.

Of course all the setting were ok and I did try reboot a couple of time.
What’s the problem? How do I solve that via ssh?

Another problem is with DLNA it was working at the beginning and I was able to access content from Smart TV, but then it stopped, I solved this installing minidlna and it has been working for a couple of days now.

Hi,

Web Gui - Please post the output of:

cat ~/.kodi/userdata/guisettings.xml

DLNA - I believe there are some upstream issues with the kodi DLNA, so being as you have got it working with miniDLNA; I would stick with that.

Thanks Tom.

Hi,

thank you for your reply.
At the following link the xml you requested: https://goo.gl/Zy2que

Thank you!!!

L

Please use OSMC paste-log to share the file.
cat ~/.kodi/userdata/guisettings.xml | paste-log

Hi,

<webserverport default="true">8080</webserverport>

Try changing the webserverport to 80.

Thanks Tom.

Hi Tom

I did change the default port with no luck.
I can still reach couchpotato and so one, but when I trey to osmc:80 I get unable to connect …

Hi,

Have your tried connecting via the IP:80?

Thanks Tom.

I did try http://192.168.1.3:80
Http://osmc:80
Http://osmc.local:80

None worked.
Where did I go wrong?
Thanks
L

Hi,

Can you ping your apple from the device you are trying to connect from?

If you a response, please provide debugging logs. You will need to enable debug, and from the client device try and access the webgui. The upload the logs and provide the link.

If you do not get a response on the ping, then you have a network issue.

Thanks Tom.

I can Ping the device.

Should I enable debug from ssh or do I have to do it from apptl tv ?
thanks fro everything

Hi,

You can enable debug logging from ssh by adding an entry to advancesettings.xml.

http://kodi.wiki/view/Log_file/Advanced#advancedsettings.xml

Thanks Tom.

Hi Tom,

sorry for the late reply, but I was out of town.
here is the pastebin link: 20:42:31.772 T:3000203136 NOTICE: special://profile/ is mapped to: special://ma - Pastebin.com
I didn’t understand how to open a ticket without the GUI.

THANKS

L

Just upload full logs with grab-logs -A

Also when logged into the device run netstat -tulnp | grep kodi

Looking at your snipped of logs it seems your webserver is still running on 8080.
If you change the advancedsettings.xml manually you first need to shutdown kodi with sudo systemctl stop mediacenter

Hi,

thank you for your kind help.

how can you tell it still on 8080?

If I edit ~/.kodi/userdata/guisettings.xml

I can see:

80

Should I check other lines?

thanks

Here is the log:
Logs available at http://paste.osmc.io/uyamujibos

20:42:46.362 T:3000203136 NOTICE: CWebServer[8080]: Started

Did you stop mediacenter before changing the file?

Also what is the output from netstat command I gave?

Hi,

I’m probably doing something wrong, so here is what I did:
triend IP:80 and IP:8080 not rworking
sudo systemctl stop mediacenter
nano ~/.kodi/userdata/guisettings.xml and checked 80
sudo netstat -tulnp | grep kodi and didn’t get results
sudo grab-logs -A
Logs available at http://paste.osmc.io/napoguyete

You mean was empty? Did you run this after you started mediacenter again?

Hi, thanks for your patience.
If I:
sudo systemctl stop mediacenter
and then:
sudo netstat -tulnp | grep kodi
I get the prompt and nothing else.
Then I
sudo systemctl start mediacenter
and
sudo netstat -tulnp | grep kodi
But I still get back to the prompt