Webserver to add YouTube Keys

I am still persevering with version 19 and using scp and command line to get keys etc into my Vero. I thought I would try now to copy and paste from my browser and I am totally unable to log in using my browser. I get a prompt appear for me to enter username and password but I just get the prompt again. Are there security blocks built into Firefox which are blocking me and if so, how can I get past the block? Of course I could be doing something wrong but have no problem pinging the vero from my laptop.

If you are talking about the Chorus2 interface, it works for me (ie I can log in with the credentials set in Services->Control).

Many thanks and yes these were already enabled. I do not however have ssl enabled. I am wondering if Firefox now will only use ssl, in which case I shall need help with certificate. It is clear where to put them but not a clue how to get them for this purpose.

Which Firefox do you have installed? Here I have 89.0 and it runs without issue connecting just with http.

I have just tried using the default pw and this does open the chorus player interface so that is progress although I have no idea why this pw is not what I have set on the system.

What I am trying to do is to be able to copy and paste from laptop to the vero an d I had understood this was the way to do it. Clearly I am off course. .

What do you mean set on the system? You mean configured under Settings - Service?

What are you to copy/paste from laptoop? As you wrote keys before maybe this is about youtube addon? Then the webinterface is a different one!

OK, clearly I am all wrong.

1st. The pw I set is the pw I set using passwd command and is the one I use to access the device using ssh. I didn’t realise using the browser to access the device needed another pw to be set, assuming that what I believe is the default pw=osmc is still not changed yet, so need advice here please. At present using the default is working.

2nd. I am trying to cut and paste keys from laptop to vero. I am doing this to get my YouTube API setup again. What I do now is put the three “keys” in a text file, send that to Vero using scp and then put the “keys” into their right place using cli.

3rd. I am doing all this because my original effort to get YT working has stopped working so I wished to start over and try and find source of my error before wasting your time.

4th. I am trying to find where the YT logs would be which should tell me where I am going wrong before I ask for more help!!!.

The Kodi Webserver password is changed at Settings - Services - Control (it is not synchronized with the OS password).

That keys are to be entered into a Webserver that is explicitly started/configured by the Youtube Addon.
Videos - Add-ons - Youtube (press context menu key when youtube highlighted) - Settings. In the HTTP Server section you can see the port it is listening on and you may have to configure the Vero LAN IP as listen IP.

As it is an addon they are just part of the general Kodi Logs at .kodi\temp\kodi.log

Try to set the HTTP Server correctly as written above and then try to access it. If all that fails you also can manually add it via SSH.

FYI, I moved this posts to a new thread as it is not related to the testing version

Hi and thanks for moving the thread.

Thanks for info about pw not being synchronised. That explains my earlier problem.
Will try and follow the rest.

Well that didn’t go as I hoped. I was able to access the Vero from my laptop browser once I knew that the pw was the default. I then tried to change it using the browser interface and have locked myself out. I do of course know the new pw but I no longer get the log in page so am stuck again.

AFAIK the YT add-on has nothing at all to do with the Chorus2 Kodi web interface, if that’s what you are trying to use. I’ve never found Chorus2 any use to be honest and I keep it in the same cupboard with the chocolate teapots.

To watch YT on OSMC you just need to follow the instructions that someone has posted in here somewhere.

Are you still having access via SSH?
Also upload logs via MyOSMC - Log Uploader that could tell what is wrong on the webserver setting.

Download WinSCP here
Configure WinSCP with the correct ip and username/password and then connect to the Vero4k+
Go to the directory /home/osmc/.kodi/userdata/addon_data/plugin.video.youtube
You can bookmark this directory for easy access in the future by right clicking somewhere and choose “Add Path to Bookmarks”
Right click on the file that you wish to edit and choose Edit → Notepad → and then just copy and paste your keys.

If you don’t use Windows I would just connect to the Vero4k+ with ssh and use the editor nano to directly edit the files.

The Kodi logs are located in /home/osmc/.kodi/temp/kodi.log , addons like Youtube also writes to this log.

Hi fzinken,
Yes ssh working well as usual.

It seems that Chorus2 is not what I need anyhow but now a new challenge in getting it working correctly.

In fact after a reboot I found my pw edit was not saved in spite of clicking save so I was able to access Chorus2 again but as grahamh has also pointed out, it is of no use to me. I would however like to improve the security by setting my own pw so if I cannot change it using said browser I shall change it using cli if you can tell me where to look for the pw.

Hi hewwra, many thanks. No windoze here and ssh is fine but was having trouble with the copy and paste. My lack of knowledge is root cause of problem!!! Using scp works fine but I was being lazy. Thanks for the help.

Upload logs and that might tell us what’s wrong.

If you don’t have any use of the Webserver (I personally have many) you can just disable it via the GUI under Settings - Services - Control and if you want to change the password you can do it in the same menu.