Weird HDMI issues with Vero

Weirdest thing I ever saw.
The Vero was working fine with my TV. One day I came home from work and it said “No input.”
Tried reseating the cable. Tried changing the cable. Tried rebooting the Vero. Tried power-cycling the TV. Nothing. “No input.”

Took the Vero off the TV and plugged it into my monitor using the same HDMI cable I’d used for the TV. No worries, everything was fine. Took it back to the TV, plugged it all back in, nothing. TV says “No input.”

Plugged a few other devices (old DVD player, Blu-Ray player, XBox 360) into the TV using that same cable. They all seem to work fine. The Vero still doesn’t. Tried switching HDMI ports on the TV. Still nothing. “No input.”
Switched out the Vero for an old Raspberry Pi. “No input.” AHA! Maybe something to do with Linux’s HDMI handling? Maybe my TV has done something that confuses Linux? I’m reaching, here…

Anybody have any ideas? I’m running out of them…

Are you able to remove the SD card from the Vero?

I wonder if re-imaging with ‘RC1’ will help your issue


I’ve re-imaged with RC2 and it didn’t change much. I’ll try RC1 as well.

  • When did you get your Vero?
  • Does it have a spring-loaded SD slot?
  • Did you install any updates before it went bad?


Received the Vero about 2 weeks ago.
SD slot is not spring-loaded.
Required updates were installed when I first set it up about a week ago, but no additional updates were installed right before it went bad.

Thanks – helps narrow it down to an earlier batch. It would be good if you could try RC1 image as a last resort.

Also worth noting: does the Vero’s red light on the SPDIF turn off after powering on for a few seconds. It should do so and indicates that the bootloader code has ran


Update: RC1 made no difference.
As far as behavior goes, the red light in the SPDIF remains on when it’s plugged into the TV’s HDMI, so the bootloader never finishes.

See if you have any luck with another SD card (to rule out the unit), otherwise contact for an RMA number


Ok, will set up another SD card.

Tried it with a new SD card, same result. I’ll request an RMA number.

I had the same issue with my Vero. Figured out it was a messed configuration file guisettings.xml.
Once deleted, “shutdown now -r -t 0” and the screen comes back on the TV.
Issue was that I had to recreate one.

I figured this out - as it was everytime the cleaning lady passed by there and touched all the cables that this happened.
I was pretty sure it had to be linked probably with her touching the power cable with micro interruption.

I’m getting the same issue here. Everything was great – ran like a champ, until suddenly I just started getting “no input” messages on the TV. Tried switching SD cards, TVs, HDMI cables, to no avail. I noticed however, on boot, that OSMC was saying that the pulse eight adapter failed to initialize. I was troubleshooting that when it started failing to boot entirely.

Per Sam’s other comments: I installed using the OSMC installer. I tried the most release release going back to RC1, but I don’t get anything. I do see that the red light is not going off, so it sounds like something is getting stuck at the bootloader. I have a spring-loaded version (SD slot) purchased a couple months ago.

Is there any kind of keystroke combination to enter bios or jumpers that I can reset?


Anyone have some ideas here? I’d love to figure out how to get this little box back up and running. @sam_nazarko is there anything you can think of that might work, or any ideas about what might have gone wrong?

Another thought - I did upgrade to the June release (2015.06-1) and it seems like it started having difficulty after that, although it wasn’t consistent. I wish I could get to the logs and see if there’s anything, but I’m not able to get it to boot using any card or different release candidates.