Western Digital PiDrive 1TB - Working until 'data endpoint not connected'


Got a 1TB pidrive from WDlabs Working OK for a couple of weeks, then did an list command (sudo ls -l) and all of a sudden, nothing…can’t access via FTP either. Still there if as you see if I do a sudo blkid command.

Tried rebooting. Any suggestions? Thanks in advance, Geoff

Are you using automount or explicit entries in fstab?
Post the output of mount and dmesg or easier just upload full logs with grab-logs -A and post the URL

Limitation of exFAT fuse I think. Try the kernel driver instead


cheers, Geoff.

thanks Sam, I like the sound of a Kernel driver. I’m noob, just bought online and plugged in. Then found in /media folder. Perfect :wink: !

I would like to use the goodness of all the kernel driver has to offer. Do you know if there is a best practice guide on how to change from fuse to kernel driver, and is exFAT ok to use as a file system? Seems to work, not withstanding comments above.

Cheers, Geoff.


I think you just need to mount it via /etc/fstab. Shouldn’t be a problem if you plan to keep it powered on all the time the Pi is powered on (which you should do, really).


thanks, will do.

Do I need to prevent / disable whatever mechanism auto-mounted USB drive to avoid mounting twice? Just out of interest, is the system that automounted to /media the kernel driver referred to by sam_nazarko? Cheers, Geoff.

hi Sam

I note that fzinken suggests not using fstab, as if for any reason USB drive needs to be disconnected then OSMC won’t boot.

OSMC is configured to automount any external device you attach (e.g. to allow you to play movies somebody brings to you on a USB stick. You also can mount them permanently via fdisk if it is always connected. But not much advantages from that (and disadvantage is OSMC would not boot if harddisk not connected) So best give it the label you want it to be mounted with.

looks like this guidance is a few versions old, Is this still the case? Cheers, Geoff

I doubt this has changed, but you can try the nofail option and then test if OSMC would boot without it.

But to be honest looking at your log file I doubt the fuse driver being the problem. Maybe you have a power or filesystem issue.

yeah, fiddled around a bit with cable and it came right…however guidance around fstab and using UUID with nofail seems good. … amazing what you learn about Linux by trying to fix stuff, and with a steer from you fellas. Great work, thanks again.

The problem lies in the fact that the exFAT driver does not handle disconnection gracefully. So spindown or cable diconnection will put you in this stuck state. fstab won’t like a drive disconnecting either; but I expect you’d be able to remount without a reboot.

well chaps, what a journey. Might need a smidgeon more assistance…:wink: Screenshots below.

`Goal: Automount external WD pidrive
Problem: When I test fstab entry I get error message ‘unknown filesystem type Linux’
What I’ve done so far: Created partition on /dev/sda 1 (followed defaults); created mount point using mkdir in /mnt called pidrive; all written OK.

When I try and test the mount using sudo mount -a I get the error message. I think fdisk reports file type as ‘Linux’ yet fstab perhaps is looking for ext3/4 or similar.

Any thoughts?


  • I probably need more specifics (nouser, rw,sync etc) in fstab entry; very happy to take suggestions here; however all I’m trying to do at this stage is test if I’ve done fstab / fdisk correctly
  • What is the best FS to use? ext4 sounds like the newest. Useful if I can mount in w7 but preference to reliable, robost pidrive.

“Linux” is a partition type not a filesystem!
Did you formatted the drive? If yes which filesystem did you use?
You then would need to define the respective filesystem (e.g. ext2, ext4, btrfs,…) in your fstab entry!

1 Like

BTW if you use a Linux filesystem you could rely again on the automount (no fstab entry) that will give you more flexibility if the drive is not permanent connected

1 Like