What's on Port 8022?

Hey peeps! I did a port scan of my Raspberry Pi 3, and I saw that I have TCP 8022 open. I google the port and saw that it’s commonly associated with oa-system. I looked up the IANA specs for the port, and all they said was oa-system. I’ve attached a list of running services too, so hopefully that narrows down the list of possibilities, since running a curl on the port just gave me a 404. It seems the initialism is too common to be easily googled. Do any of you know what service 8022 is associated with in this instance?

System info: I’m running the latest osmc image for my Raspberry Pi 3, and hardly any additional packages.

The scan:

nmap 10.0.0.*
Nmap scan report for
Host is up (0.0065s latency).
Not shown: 994 closed ports
22/tcp   open  ssh
111/tcp  open  rpcbind
139/tcp  open  netbios-ssn
445/tcp  open  microsoft-ds
8022/tcp open  oa-system
8080/tcp open  http-proxy

Nmap done: 256 IP addresses (6 hosts up) scanned in 41.13 seconds

Here’s what I got from a curl:

james@ubuntu-laptop:~$ curl osmc.local:8022
HTTP/1.0 404 Not Found
Server: BaseHTTP/0.3 Python/2.7.9
Date: Sat, 12 Nov 2016 22:32:53 GMT


osmc@osmc:~$ sudo service --status-all |grep +
 [ + ]  avahi-daemon
 [ + ]  dbus
 [ + ]  fake-hwclock
 [ + ]  hdparm
 [ + ]  kmod
 [ + ]  nfs-common
 [ + ]  nmbd
 [ + ]  ntp
 [ + ]  procps
 [ + ]  rc.local
 [ + ]  rpcbind
 [ + ]  samba-ad-dc
 [ + ]  samba.distributed
 [ + ]  smbd
 [ + ]  ssh
 [ + ]  udev
 [ + ]  udev-finish
 [ + ]  urandom

It isn’t the normal port used by the kodi remote control but whatever it is is powered by Python so my guess would be a kodi add-on.

You can fins out the process using the port with one or more of the following:

sudo lsof -i | grep LISTEN
sudo netstat -lptu
sudo netstat -tulpn

@yknivag’s advice is good (apt-get install lsof first).

I get this on a vanilla OSMC install:

22/tcp open ssh
111/tcp open rpcbind
8080/tcp open http-proxy

But at times, you will see random ports open, i.e.

22/tcp open ssh
111/tcp open rpcbind
8080/tcp open http-proxy
10000/tcp filtered snet-sensor-mgmt

The description is just an nmap based one, but of course > 1024 is unprivileged and can be used by anything.

Did you install anything?
Did you port forward SSH at any point?

Otherwise shouldn’t be anything to worry about :slight_smile:


I don’t remember installing it and I just ran it on my box to check the syntax. Then again it is 23.30! :sleeping:

1 Like

Looks like it’s Kodi!
ran osmc@osmc:~$ sudo lsof -i | grep LISTEN
kodi.bin 598 osmc 25u IPv4 12352 0t0 TCP *:8022 (LISTEN)

This raises the question then, do the addons run under the kodi process?
I searched in the addons folder and found a settings.xml for the Notify Addon that specified port 8022.

I changed the config so it defaulted to 8023, restarted kodi, and then it just disappeared, even after putting config back. So I guess I broke it. Oh well, mystery solved haha. Thanks folks!

Same functions as Yaste still nice to know there are alternatives, cheers for that :slight_smile:

although it seems that the developer has given up on further reading


well lets hope that he picks it up again.

Yes add-ons run, for the most part, as the kodi process. Glad you found out what it was and thanks for marking the thread as solved to help others.