When rebooting Vero V with TV and receiver turned off, 720p is the highest mode I can select after latest update

I sometimes reboot my Vero V through SSH when I updated a script or updated Plex media server. When I do it with the receiver and TV off, the highest selectable resolution in “system”, “display” is 720p.
If I reboot the Vero V when the receiver and TV are on, also through SSH, all modes that are supported by my TV are selectable again.
My receiver is a Denon AVR-X2400H and my TV is a Philips 43US6503

Here are the logs, first the 720p locked one:

Here is the unrestricted one:

I suspect that it has to do with the latest update, but let you guys be the judge of it :wink:

Can you post logs via My OSMC? We would need to see more than Kodi logs.

I can, would like to sanitize them, where does My OSMC store the logs?

They are uploaded to https://paste.osmc.tv when you publish them.

1 Like

Sanitized (because of Plex tokens) when it boots correctly with everything on:

Here is the log when it boots with 720p as highest available setting:

Thanks, will check shortly. But if your equipment is off when booting we might not be able to read an EDID and will fallback to what we consider to be a safe resolution.

There are ways to override this however and we do detect hot plug events and adjust resolution on the fly when capabilities change.

I understand what you say, would be nice if this can be fixed. I didn’t have this behavior when I was on the previous OSMC version.
Just an observation as a user :wink:

Your AVR is not sending an EDID when it’s ‘off’. HDMI devices have the option to use the power on HDMI to send an EDID and I think most do that these days. Is the AVR truly off or just in standby?

Try turning off the HPD lock.

Sorry, you are correct, I didn’t use the correct name which can be pretty annoying as off and standby are indeed very different.
Both devices are in standby mode.

If I turn of HPD, I get out of sync issues.

This hasn’t changed in the last update. I suspect you just haven’t been rebooting your device remotely when your equipment is off.

There isn’t really anything to fix.

But looking at your logs now: the problem is likely caused by the fact you’ve enabled HPD Lock under Settings → Display. I’m not sure why you have done this, but by doing so you prevent us from updating the resolution when you turn your AVR and TV on by suppressing hot plug events.

Try disabling that setting and then rebooting with equipment off. I suspect it will solve your issue.

I will try turning off HPD lock, hope the out of sync issues will not return then though.

Let’s get some logs for that case, then. It shouldn’t affect things for playback. The latest update should be better at a/v sync - are you saying it’s worse for you?

I can’t see how HPD Lock would prevent synchronisation issues unless it’s inhibiting refresh rate changes altogether; but then you might as well disable Adjust Refresh Rate entirely (not recommended).

Is this separate from the 25p issue?

Yes, completely separate. I started watching that series just after updating and saw the jerky video, checked the resolution and it triggered me seeing the 720p as maximum resolution.

At least, disabling HPD solved the reboot issue with my stuff in standby. If I get the sync issues, will report back with logs on that with a separate topic! Thanks.