When using playlist 'watch later' in YT add-on I get message playlistid not found

Since the option ‘my subscriptions’ no longer works (since beginning of Dec 2020) I now use the option to add videos to my ‘watch later’ playlist. When I use the youtube add-on on my kodi raspberry pi3b+ I get a lot of errors when getting back to that playlist, be it after a video has ended or by selecting the playlist. The error message appears briefly on the screen and when I try again either the playlist is shown, or I get the same error a number of times. Eventually I do get my playlist. But it is very annoying. Anybody has any idea what is going on?

You should really be addressing this issue with the developer of the YouTube addon. OSMC is not involved with the development or support of Kodi addons.


This is indeed the case. But do keep in mind @anxdpanic is a member of the OSMC team, so he might be able to advise here, although this isn’t quite the place for it.

I have done just that. Update: seems I was not the only one. @anxdpanic suggested a solution I already tried myself, but it is ‘cumbersome’ to say the least. There is another strange thing though: when using the ‘my subscriptions’ option, while that was still working, about 30-50 % of the video’s wouldn’t play. Now that does no longer happen. Seems ‘you gain some, you lose some’ , isn’t it?

A lot of newer videos won’t work at >360p unless you enable MPEG-DASH. See below.

Enable Settings - MPEG-DASH - Use MPEG-DASH and Settings - MPEG-DASH - Use for videos. Then set your quality in the same section.