When will OS X mount error solved?

We think we have a solution but it needs building and testing. I need to get @srmo to set up the OS X build environment again.

I’ll see if I can resolve Qt issues for Stretch shortly. SUSE looks to be working here.



thanks for the fast answer :smiley: I’ve seen that the Suse site is up again but the repo won’t work with Debian 9 Stretch :frowning: So I’ve to bite in that sour apple and have to install Debian Jessie again :confused:

Isn’t it possible with the text file on a usb drive like I mentioned? Or must I put some file on the SD Card that the system will installed on usb? The rest I’m able to configure over OSMC itself.

Great product btw, you people have done a great job, thanks! :smiley:

Boot a Ubuntu live DVD in Virtual Box and you are up and running in 10 Minutes

I’ve tried it with a Debian Jessie VM but it didn’t work.

What didn’t work exactly?

Can you try this new version of OSX installer?

1 Like

The installer there also had problems mounting the partition and tried to finalize after it copied the data but unfortunately I didn’t saved the console output.

Anyways, I’ve solved the problem. I have installed a fresh copy of OS X with Debian Jessie on virtual box and yey, it seems to work. The linux installer finished now without any error or problem.

It’d be nice to fix the OS X issue.
I don’t have regular access to a Mac with an SD slot. If you do, I’d appreciate it if you could test again and paste the log.

Tried the new installer and it worked perfekt, like the old one. 1.000 times thank to you and the team! :smiley:

Thanks for testing. Glad it worked. I’ll get a bit more feedback and if all is well get it pushed out.


Sam, same here. Newbie on the Rasp tried the install from the website to no succes. Using 10.12.5 which causing troubles over other programs as well. Don’t know how, but with the latest dropbox installer no problems and i have a fresh install. (iMac 21.5 mid 2011, OSX 10.12.5)

Brilliant. Looks like we owe @srmo a beer :slight_smile:

@sam_nazarko Cool! I’ll take a Weizen

I’m always confused why there is an installer for any Unix system. dd isn’t hard. Actually it is simple. Every Unix-like system has this magical dd command.

$ sudo dd if=/path/to/file.img of=/dev/sdZ bs=1M

Write to the full device name of the SD card, not some partition (sdZ1) on the SD card. It always confuses me how much effort is spent to avoid gaining a tiny bit of knowledge.

People don’t want to use the command line.
The installer also allows you to set up networking; install target etc in a very user friendly way.

@Spammer456 please tell me more about dd, as if I don’t own man-pages. It always confuses me that people think that they know something about a stranger they’ve never met in their life but wuhuu you’re such a linux genius, thanks :wink:

ps.: with the big ‘M’ in your block size argument the command you mentioned won’t work on OS X, even :smiley:

@sam_nazarko It’s not because I don’t like command line, actually I prefer it than running some gui’s but unfortunately I couldn’t recognize how to prepare the content of the SD Card/USB Stick after transferring the image the good old way so OSMC would be installed on the USB Stick instead of the SD Card.

But generally you’re right most people don’t like command line and the installer is very nice so I only can mention again that you guys really did nice work and I think I know what I say cause I use XBMC since the XBOX one :smiley:

@Sam - I’m not complaining about the 1st-boot installer where network gets configured. That is necessary. Just wish it worked easier with a remote-only system. Hooking up a keyboard or mouse is a huge hassle. Generally, I find it easiest to setup a DHCP reservation for the NIC being used to avoid having to deal with the network interface stuff.

A tool seems to be the ‘go-to’ method to move an image file to an SD card when dd does it easily with a tiny bit of knowledge that is useful for many other reasons. I would find it helpful if there was a tiny mention that dd could be used to place the image on the SD. It has been months since I pulled the image down.

Download - OSMC says:

You can also download disk images.

is a little vague. Would be helpful to mention that ‘dd’ or any other imaging tool could be used with the image files rather than using installer.

@somebodywhoisntme - I don’t know you, but assume you can use a web search. Google found this pg: How To Create Disk Image on Mac OS X With dd Command - nixCraft
I never claimed to be a Linux genius.

Sam is a saint in my book for dealing with people like me and others always wanting an fool-proof method to accomplish anything.

@Spammer456 I dont need a web search for it, I don’t even tried your command to know that the argument was wrong. I don’t know what you had get wrong but I didn’t wrote anywhere that I’ve problems to get the image to the SD. I only wanted to know the steps after the image transfer for getting OSMC installed to a USB stick instead to the SD as I mentioned before. This was possible in the past but I forget the whole process even if it was easy like putting a usb.txt file on the usb drive or something similar but if I get a fresh installer GUI who does everything for me why should I don’t use it?

And I think it’s enough to mention that one can download images. If someone knows what a image is someone probably knows how to use it and if not someone should download and use the installer.

I am also trying to install from Mac 10.12.6 but no luck. The OSMC installer can’t see the SD card.

Hi, as amateur i find out easy way to kick this problem.
1.download this app balenaEtcher - Flash OS images to SD cards & USB drives
2.download some of these disk images from here Download - OSMC

  1. run Balena and mount disk image straight on your SD.
  2. put SD in your Pi … done. Instalation will start.

Hope it will work for you too.

Me on Catalina OsX