OSMC Installer for Mac on Sierra 10.12.5 Ends up with error

Thanks Sam, I look forward to hear back and Good Luck

If you have problems booting and the SD card is problematic in OS X, then it may be the SD card.

I simply fails to extract and write image in the SD Card, The Installed fails mounting and un mounting and pops up with Error Message, on Three Different Cards, SanDisk, Kingston 16Gb Class 10 Cards, out of which two cards are Brand New Never Used, and one is my previous.
It is the Installer fails. Card I am 100% Confident not have issue. because all three cards fails to be written image by the Installer.
and if used Windows Installer then there is no problem in writing Cards Anor Booting.

That’s really, really strange. I can reproduce that on my MacBook Pro with 10.12.5
@Wahaib1981 after the failure message from the installer, could you go to the terminal and do a manual “diskutil mount /dev/” where is the disk partition created by the installer, like /dev/rdisk2s1 and see if this works?
We are hunting this, some strange behavior, maybe due to a recent update, makes our current mount approach to non-Volume mountPoints not working. I.e. we call diskutil with the -mountPoint option, which isn’t even working for me in the terminal -.-

Hi Sam,
I simply fails and unable to mount even via Terminal,

here is the screenshot

Please try diskutil mount /dev/risk2s1 in terminal after closing the installer

Stil Fails,
I think the installer unable to re-name the SD card thats why.

This is the message in terminal

Unable to find disk for /dev/risk2s1
Hashams-MacBook-Pro:~ wahaib$ diskutil mount /dev/risk2s1
Unable to find disk for /dev/risk2s1
Hashams-MacBook-Pro:~ wahaib$

Oh, sorry. My bad, there’s a d missing in the command ^^
diskutil mount /dev/rdisk2s1

This time it is able to mount in the terminal

But Carefully check the Screenshot, installer is writing image to “dev/rdisk2” but on the popup error windows it say could not mount device to “dev/rdisk2s1” (These are two different name I guess)


Unable to find disk for /dev/risk2s1
Hashams-MacBook-Pro:~ wahaib$ diskutil mount /dev/rdisk2s1
Volume NO NAME on /dev/rdisk2s1 mounted
Hashams-MacBook-Pro:~ wahaib$

Thanks for verifying. It’s ok. We write the image to rdisk2. This image contains one partition. It will become partition rdisk2s1. As explained in the other thread you linked, we mount this partition to do some pre-seeding for the target installer (wifi, etc). We have to rewrite the whole installer anyway, to solve some HiDPI issues and to make it more robust across platforms, so we can try to get rid of such annoyances.
But this takes time, and developers :slight_smile:

PS: at this moment, we are thinking about a quick fix for this 10.12.5 issue, but not sure when we can provide it. We need to make sure to not introduce any regression bugs. Please be patient. And then we have High Sierra lurking at the horizon …

1 Like

Same problem here. I tried 3 different SD cards with 2 different ‘setups’ (Mac SD-slot and SD-card reader via USB). All 6 combinations resulted in the ‘could not mount’-error.

I suspected corrupt SD cards, but when I ended up doing a manual installation, everything worked fine.

Could you elaborate the steps for manual install ?

Use dd. A search here will get you some posts


I shared the steps in this comment:

Any news update on this fix ?

Look here. Sadly, the topic was split in 4 - damn you double posts! ^^

Fix is now available on osmc.tv/download.

Same error in My macOS 10.15.4

OS Ver:


Unfortunately due to new security restrictions, the latest macOS version is not supported

You could write the image manually for now.