OSMC Installer for Mac on Sierra 10.12.5 Ends up with error

PS: at this moment, we are thinking about a quick fix for this 10.12.5 issue, but not sure when we can provide it. We need to make sure to not introduce any regression bugs. Please be patient. And then we have High Sierra lurking at the horizon …

1 Like

Same problem here. I tried 3 different SD cards with 2 different ‘setups’ (Mac SD-slot and SD-card reader via USB). All 6 combinations resulted in the ‘could not mount’-error.

I suspected corrupt SD cards, but when I ended up doing a manual installation, everything worked fine.

Could you elaborate the steps for manual install ?

Use dd. A search here will get you some posts

Hi,

I shared the steps in this comment:

Any news update on this fix ?

Look here. Sadly, the topic was split in 4 - damn you double posts! ^^

Fix is now available on osmc.tv/download.

Same error in My macOS 10.15.4

OS Ver:


LOG:

Unfortunately due to new security restrictions, the latest macOS version is not supported

You could write the image manually for now.

Sam