OSMC Installer for Mac on Sierra 10.12.5 Ends up with error

The OSMC Installed for creating SD Card ends up with error on Mac OS X Sierra 10.12.5 after downloading after extracting when starting to install.


The installer should produce some logs. Should be in your home folder.

Can you pull these?


Hi Sam,
I here is the link to Log File. (Dropbox - File Deleted)

I have tried two Different SD Cards, Brand New. moreover I have even fresh re-installed my OS X for Mac Book thinking may be some Software Bug or etc.
Even Checked my Card Reader for MacBook Pro by copying Formatting mounting un-mounting all is fine but error keeps coming

Something is mounting the disks before we can get a handle on them. Perhaps some anitvirus software.

nop, i have got any sort of Antivirus installed. I am only Using Security Software (Ad-Guard & Hands Off for Blocking Adds from Websites etc.)
I have tried the Same on Older Version of Mac OS X it works fine though. I am not sure why not on Sierra

We tested it on Sierra back in September; so it should still be working.

I searched google and I see some one else reported the same issue just few weeks back in June
here is the Link for your Reference

Indeed – we are getting about 500 downloads of the OS X installer a day though. Did this only occur after a recent update? Have you ever used the installer successfully on Sierra before?

Yes I have been using the installer on Sierra just fine like a 2 or 3 months back. but now it doesn’t. initially I thought I have lots of stuff installed and could not figured out that the problem is with Card, Card Reader, or my Mac Software.
I bought 2 brand New SanDisk Class 16Gb Cards. and 3rd was my previous Card. they all were fine If I used windows, then I tested my Card Reader, and then yesterday I even Clean Installed my Mac OS X.
Only then I reached the Conclusion that there is some thing wrong with Installer.

The installer hasn’t been updated since February, and even then it was minor (to add Vero 4K as a device).

If it worked a few months ago and doesn’t now, then something else may have changed. I’ll see if I can get someone to test it on OS X quickly.

Thanks Sam, I look forward to hear back and Good Luck

If you have problems booting and the SD card is problematic in OS X, then it may be the SD card.

I simply fails to extract and write image in the SD Card, The Installed fails mounting and un mounting and pops up with Error Message, on Three Different Cards, SanDisk, Kingston 16Gb Class 10 Cards, out of which two cards are Brand New Never Used, and one is my previous.
It is the Installer fails. Card I am 100% Confident not have issue. because all three cards fails to be written image by the Installer.
and if used Windows Installer then there is no problem in writing Cards Anor Booting.

That’s really, really strange. I can reproduce that on my MacBook Pro with 10.12.5
@Wahaib1981 after the failure message from the installer, could you go to the terminal and do a manual “diskutil mount /dev/” where is the disk partition created by the installer, like /dev/rdisk2s1 and see if this works?
We are hunting this, some strange behavior, maybe due to a recent update, makes our current mount approach to non-Volume mountPoints not working. I.e. we call diskutil with the -mountPoint option, which isn’t even working for me in the terminal -.-

Hi Sam,
I simply fails and unable to mount even via Terminal,

here is the screenshot

Please try diskutil mount /dev/risk2s1 in terminal after closing the installer

Stil Fails,
I think the installer unable to re-name the SD card thats why.

This is the message in terminal

Unable to find disk for /dev/risk2s1
Hashams-MacBook-Pro:~ wahaib$ diskutil mount /dev/risk2s1
Unable to find disk for /dev/risk2s1
Hashams-MacBook-Pro:~ wahaib$

Oh, sorry. My bad, there’s a d missing in the command ^^
diskutil mount /dev/rdisk2s1

This time it is able to mount in the terminal

But Carefully check the Screenshot, installer is writing image to “dev/rdisk2” but on the popup error windows it say could not mount device to “dev/rdisk2s1” (These are two different name I guess)


Unable to find disk for /dev/risk2s1
Hashams-MacBook-Pro:~ wahaib$ diskutil mount /dev/rdisk2s1
Volume NO NAME on /dev/rdisk2s1 mounted
Hashams-MacBook-Pro:~ wahaib$

Thanks for verifying. It’s ok. We write the image to rdisk2. This image contains one partition. It will become partition rdisk2s1. As explained in the other thread you linked, we mount this partition to do some pre-seeding for the target installer (wifi, etc). We have to rewrite the whole installer anyway, to solve some HiDPI issues and to make it more robust across platforms, so we can try to get rid of such annoyances.
But this takes time, and developers :slight_smile: