When will Vrc-1100 volume issues be fixed?

Since many versions, kodi accepts only the first click on volume up or down, but you cannot keep the volume pressed to change a greater amount up or downwards. Instead you need to press and release the volume button many times. This once worked, how can this be fixed?

Believe Hama is working as expected in Isengard


It’s a shortcoming of a poorly designed remote. If the volume keys are mapped to say number keys 1 and 4 then they repeat as desired, however on the volume keys they don’t repeat. It’s a hardware issue.

Thanks for responding, possibly the hardware or dirver design are poor, but why does it work on other systems? On an old XBMC client under Windows, the repeat of the volume keys works perfectly fine, I tried with the same remote, so there must be a way to do this…

That’s a completely different driver under a completely different OS, it’s expected that function may not be identical.

Okay, I am not as deep into that topic, but what’s wrong with my argument then: either the driver used in Linux, or the implementation in OSMC is faulty then. But it’s not a hardware issue of the VRC-1100, and since this device is widely spread, it is highly appreciated if all features were working as expected. So if somebody can figure out what the problem actually is, this would be highly appreciated.

And as far as I remember, that feature used to work in very early versions of RaspBMC, but I cannot check that at the moment since I do not have any older versions.