Where can I find Raspbmc?

Hello,

I just downloaded OSMC to give it a try, but since Airplay almost doesn’t work (couldn’t make it work with Music on iOS and after a dozen of tries with iTunes on Yosemite I could hear some fragments of sound and it stopped after a few seconds), I would like to reinstall Raspbmc, as everything was working fine with it. But the Raspbmc home page has no link to download it. Where can I find it?

Hi.

You can find the last Raspbmc image at the bottom of this page: Download - OSMC

Thanks! I didn’t see it, sorry!

You won’t find Raspbmc any better for AirPlay, the problem is Apple is progressively breaking compatibility with each major iOS release.

By going back to an older version of Kodi your problem will get worse not better. BTW output from iTunes on OS X is not supported, only AirPlay from iOS devices.

Airplay from iTunes on OS X Yosemite works perfect here. It even works if you set it to Airplay in the sound preferences. As the main soundcard.

Hello DBMandrake,

I used to watch movies using Airplay on iTunes and Raspbmc. And Airplay was working almost perfectly on Raspbmc with iOS 8.3 at least. I did’t try with iOS 8.4, though.

Marktheis,

Do you have a recent Mac? Mine is a late 2008 MacBook. It doesn’t support Airplay mirroring for example.

late 2011 MacBook Pro. That shouldn’t matter though.

I was only talking about audio. Mirroring has never worked for me.
But audio works much better on OSMC than on Raspbmc. For me at least.

Mirroring has never been supported by Kodi.

The toggle switch will appear but you must leave it off or the device will disappear from the list entirely.

Hum, how to install Raspbmc from img file?

OK, I followed the instructions in the following page and it worked well: Installing operating system images - Raspberry Pi Documentation

And now Airplay works well again. So there IS something wrong with Airplay support in OSMC (note that I use it on a Rasperry PI).

Sorry but I cannot reproduce your problem. AirPlay is working absolutely fine for me on OSMC on my Pi 2.

Both music from the Music app and Video from an app such as Instacast, on my iPhone 6 running iOS 8.4.

Because there are no mass complaints of AirPlay being broken on the forum I would suggest that there is something peculiar about your network that is causing your issue.

The most common cause is the configuration or firmware of your wireless router - a few people who have had AirPlay problems have fixed it by either updating their router firmware or checking their router configuration.

Weird, as everything is fine on Raspbmc and I didn’t change anything in my network configuration (my router is the current Time Capsule running the last version of the firmware). Could it be related to the power of the machine, as I have the original Raspberry PI and you use a Raspberry PI 2?

I just reinstalled Raspbmc on the SD card that was running OSMC so I can not try again with OSMC now. I’ll give it another try to OSMC later. Maybe I’ll wait for another update or two.

To my slight surprise I got Apple Music (with a streamed song) to play over AirPlay to my OSMC-running Raspberry Pi (Model B) only last night.

But I’ve always found it quite erratic, in all builds of Kodi (and XBMC Frodo before it) on Raspberry Pi. I never have much luck with video.