Where do I set the time zone in OSMC?

After the change from daylight savings time my OSMC Kodi displays time one hour off.
I have not found any place to enter the time zone or daylight savings setting…
My OSMC seems to be from August 2015.
Do I need to reboot the RPi2 after the daylight savings time change to get the correct time again?
I have seen mention of an “International” setting but for the life of me I cannot find it. Please advice step-by-step how to reach any setting concerning this problem.

In settings go to Appearance then International

Thanks, found it. Of course since the GUI is translated one has to figure out what the English terms would have been translated to…
Now I have correct time.

BTW: How do I ensure that OSMC is the latest version?

Wiki helps as usual
https://osmc.tv/wiki/general/finding-out-what-version-of-osmc-you-are-on

OK thanks,
this is what I got:

osmc@osmc:~$ grep Kodi .kodi/temp/kodi.log | head -3
06:52:42  11.925102 T:1956884480  NOTICE: Starting Kodi (15.1). Platform: Linux ARM (Thumb) 32-bit
06:52:42  11.925178 T:1956884480  NOTICE: Using Release Kodi x32 build (version for Raspberry Pi)
06:52:42  11.925265 T:1956884480  NOTICE: Kodi compiled Aug 30 2015 by GCC 4.9.2 for Linux ARM (Thumb) 32-bit version 3.16.7 (200711)
osmc@osmc:~$ grep VERSION_ID /etc/os-release
VERSION_ID="2015.08-1"

Is this the latest version?

OSMC now has monthly updates so, nope to the latest one.
Latest one is 2015.10-1

If you enter My OSMC you will see the version in the bottom corner. Looks like you are on August 2015. October 2015 is now available. You can upgrade via My OSMC -> Updater

Sam

I used MyOSMC->Updates->Check for updates
It went away and started displaying messages on top of the screen for a while showing downloads of “stuff”.
Then it seemed to start a main download so I went away a few minutes. When I came back I had the following message box on screen:
OSMC UPDATE ERROR
UNABLE TO CONNECT TO THE UPDATE SERVERS
PLEASE TRY AGAIN LATER
OK

Cannot understand why it failed to connect to the servers after some time of downloading stuff when it clearly WAS connected to some servers…

What do I do now?

UPDATE:
When I hit OK then a new mesage appeared (all in shouting caps):

OSMC UPDATE AVAILABLE
Updates have been downloaded, but Kodi needs to exit to install them.
Would you like to exit and install the updates now?
YES NO

THis seems very dangerous now, will KODI break by trying to install an incompletely downloaded update if I hit YES???

Shouldn’t do any harm as APT is pretty careful about what it does, BUT I would just hit no, then go back into check for updates again.

Remember that OSMC is using two sets of updates servers - OSMC servers and Raspbian/Debian servers for the underlying parts of the operating system. It’s perfectly possible for there to be an issue with the Debian servers while you can still download updates from the OSMC servers - it’s happened before.

OK,
I said No then repeated the process and it ended the same way after sitting at “0% Starting download” for a minute or two.
Is there a way to do this update from the command line via SSH? It seems like the integrated function in Kodi does not work.

While I would wonder that it is a problem with the MyOSMC updater you always could do

sudo apt-get update && sudo apt-get dist-upgrade

Thanks!
That did work and I also got to see what was going on while it worked.
Much more comfortable with the SSH console display.
My system is now on 2015-Oct level.

The SSH method does not clear old kernel packages, so your disk may fill up, especially with /boot.

In future, always upgrade via My OSMC. It’s completely safe.

Except I tried twice with several hours in between and the message was that it did not get a server connection. :worried:
Then I made the SSH connection and upgraded via apt-get, which worked directly.
So there must be some problem with the MyOSMC way of updating manually.
Should I set it to automatic updating and how would that work given the way the manual trigger for MyOSMC update failed?