Why is 1080i no longer an option?

Have an older LCD TV with the highest output being 1080i. This worked fine for me up until the latest update. Now it is no longer an option in the resolution settings menu, the highest it will let me go is 768p. When I select “hdmi_ignore_edid” in the Pi Config it increases my options up to 1920x1080p, but crucially no 1080i.

What gives? Was 1080i support left out of the latest update? Please help

If your native resolution is 1080i and 1080p is not supported by display (detected through edid) then kodi should default to 1080i (shown as DESKTOP in the list of resolutions). Does that not happen?

If you want to force 1080i regardless then try adding to config.txt:


That will force 1080i60. For 1080i50 use hdmi_mode=20.

Thanks @popcornmix, you’re a bloody lifesaver!

Kodi wasn’t displaying 1080i in the DESKTOP list of resolutions. But after I wacked those commands into config.txt it worked like a charm. Thanks so much again mate.

Just to clarify - DESKTOP is one of the resolution choices.

More specifically it tells Kodi to leave the resolution alone and use whatever resolution the system initially booted in. Thus if you override the resolution in config.txt at early boot time it will remain in that resolution when Kodi loads.

If you choose any other option in Kodi it will cause Kodi to switch the resolution when it starts.

Thanks for the clarification, but when I previously selected DESKTOP the resolution still only maxed out at 768p at that time. But thankfully it’s all sorted now.