Why is it so difficult to read windows shared folders?

Okay, what I have tried so far and historical connections.

I have a Dune 4k media player and it is starting to play up, I think its been used to death. On there I connect to my main PC (Windows 10 Pro) where I store all my CD, DVD and Bluray rips. Using Winnfsd I can share all the folders I want and its okay, not the most reliable but generally it works. We have other computers and I can access shared folders without any issues from them.

Because my Dune was playing up I decided to get a different media player (Vero 4k+), I read around various forums and this came up as being a good one to connect to shared folders.

So I’ve been trying to add the nfs folders to my Vero and I’m getting nowhere. I can see on winnfsd command prompt screen that it is trying to do something but it just say noimp, or something similar.
I tried working through this ([How To] Add NFS server capabilities to Windows (free)) and when still nothing was occurring I tried the optional part
“- Optional, add your windows pc’s ip on (client) Kodi’s file manager as an NFS source: Settiings/File Manager/Add source/Browse/Add network location/Protocol: NFS, Server address: IP of win pc/OK/give-a-name/OK.” as soon as I select OK the first time it locks up the Vero, only a power cycle will get it going again.

So I tried adding files without nfs, just using “smb://user:password@SERVER/sharename/folder” I managed to get all the setting done (SMB version 1.) so it will talk and for some reason I can only seem to add files from one drive. I’ve checked and the share settings are the same for each. I’ve removed them all from windows share and put them back and its still the same, it has to be a windows setting but I cannot work out what it is.

I would prefer to have them connected through nfs if anyone can suggest how I can get it working please?


I suggest trying:

Thanks Tom.

I’ve already sent this resource to the customer as he contacted us via Facebook Messenger. I asked him to make a post where so we could work out where he was getting stuck. I’ll have a read now.


Is there a specific reason to use NFS and not SMB?
If you’ve enabled NFS, can you let us know how you’ve enabled it? Are you using Windows’ implementation of it or a third party solution?

Is it possible for you to boot up the Dune and show us a couple of photos of how shares are mounted on that. IP addresses are internal, so don’t need to be hidden and this should let us know how to transfer this to your OSMC device. The only thing you’d want to avoid publishing would be your password.


I’ve been able to set up NFS exports on my Windows box using Hanewin NFS server. That seems to work quite well with my Vero 4K+.

I thought i’d play around with this and try, is it this software you are referring to?

Version 2.4.0 ?

Hi Sam, I think I have fixed it.
I was not using the exact directory name, e.g. I was using mp3 when I should have used Mp3, also I was using nfs://SERVER/L:/mp3, when I looked at the Dune setup I noticed that the : was missing. I removed the : and got the directory names correct (nfs://SERVER/L/Mp3) and bang it works.

Thanks for the heads up on looking for the way I did it on the Dune :wink:


Thanks angry.sardine, see notes below, got it sorted.

@joakim_s, yes it is that, and that version.

Thanks for looking too, please see notes below, I got it working thanks.

1 Like

Glad to hear this is now working. If you have any more questions give us a shout.