Wi-Fi Dropping Out

I have been using ethernet cable to connect to internet on my rasp pi 3, running the latest version of OSMC. I have been using ethernet for nearly 10 months but prior to that I was using wi-fi (with no issues) for approx 12 months

Recently I copied my card onto another rasp pi 3 for use in another room with wi-fi. WI-fi started but dropped out after a few minutes.

Tried the original pi - this was doing the same - wi-fi starts but drops out.

Tried on a different router - the same.

Checked channel on router - uses channel 11 (and no other issues with other wi-fi devices).

Logs are here:


I did read about checking the power management using a util called wireless-tools but this errors-out when I try to install this.

I am using the standard dedicated power supply, supplied with the pi.

Hope someone can provide advice on this.


My guess is that you didn’t change the hostname, and many other settings. Like if you had static IPs.

Your best bet would be to do a new installation on the new Pi. Once up and running, you should be able to copy the contents of .kodi if needed.

Thanks for the response. I will look into that.

However why would the original pi (where I usually use ethernet) not work either - same symptoms - connects for less than a few minutes and then drops out?

I then took the (original) pi to a friends house and tried it on their router and same issue.

If there are duplicate names, IPs or possibly even MACs, both systems will be fighting for the same name/IP etc. and cause random problems.

You have installed network manager:

ii  network-manager                      1.6.2-3                                     armhf        network management framework (daemon and userspace tools)
ii  network-manager-openvpn              1.2.8-2                                     armhf        network management framework (OpenVPN plugin core)

This will almost certainly conflict with connman, which is what OSMC uses.

I see that you have also included jessie-backports in your APT sources.list file. That might also cause a few issues.

Thanks for the response.
Network-manager was installed to use openvpn (which I don’t use anymore). Initially when I installed openvpn (> 12 months ago) I was using wi-fi so it is strange how this might cause an issue now.

I tried to uninstall network-manager but I this seemed to unistall connman (or do something which stopped me connecting either through wi-fi or ethernet). Therefore I could not test to affirm whether this was the issue or not.

I therefore just installed a fresh OSMC on the Pi # 2 and it connects using wi-fi, so it’s not a h/w or router issue.

Pi #1 I will continue to use ethernet, so not a problem there.

Thanks all for your assistance.