Wi-Pi and OSMC - install? [SOLVED]

I’ve got a Wi-Pi that I’ve never used and would like to use it to connect my second Pi model B to my network.

I thought this wireless adapter was supported out of the box. Seems not to be the case with OSMC under the Alphas.

Could someone please give me some pointers how I can get this going.

Thanks.

dmesg:

[2.536639] usb 1-1.2: Product: 802.11 n WLAN
[2.536655] usb 1-1.2: Manufacturer: Ralink
[2.536670] usb 1-1.2: SerialNumber: 1.0
[4.590562] random: systemd urandom read with 81 bits of entropy available
[4.711555] NET: Registered protocol family 10
[5.851713] systemd[1]: Cannot add dependency job for unit display-manager.se                                                                                        rvice, ignoring: Unit display-manager.service failed to load: No such file or di                                                                                        rectory.
[6.328801] fuse init (API version 7.23)
[6.378775] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[7.268724] systemd-udevd[95]: starting version 215
[8.748986] cfg80211: Calling CRDA to update world regulatory domain
[9.388709] usb 1-1.2: reset high-speed USB device number 4 using dwc_otg
[9.502260] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 5390, rev 0502 d                                                                                        etected
[9.504777] random: nonblocking pool is initialized
[9.770674] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 5370 detected
[9.833220] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[9.842536] usbcore: registered new interface driver rt2800usb
[9.845207] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data                                                                                         may be corrupt. Please run fsck.
[11.409747] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
[13.540667] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[13.541404] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[13.654739] systemd-journald[75]: Received request to flush runtime journal f                                                                                        rom PID 1
[13.876091] Adding 131068k swap on /swap.  Priority:-1 extents:6 across:27033                                                                                        6k SSFS
[14.688924] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmwa                                                                                        re file 'rt2870.bin'
[14.700998] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detec                                                                                        ted - version: 0.29
[15.036205] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[15.072316] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[15.077397] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC5E                                                                                        1
[24.651800] Console: switching to colour dummy device 80x30

Might wait till Wifi GUI is added in next release.

Had a look here but no go: Enable wifi under GUI

Ok, had no luck with OSMC.

I set up a Raspbmc backup (final build) and tried the Wi-Pi there too - no luck there either :frowning: No connection, nothing!

Searched and searched and found this: http://forum.osmc.tv/showthread.php?tid=14393&pid=103283. Got it working on Raspbmc with the firmware @DBMandrake mentioned in the above post. At least with Raspbmc it seems to have been a firmware issue.

Maybe @sam_nazarko can have a look at incorporating the “correct” Wi-Pi firmware with OSMC.

Your log shows it is RT2870 based and that firmware loaded.

Should work OK once the GUI is done

Sam

My Wi-Pi didn’t work either (or rather the network setup didn’t work) untill I went through the manual guide in this thread. Now it works perfectly - and after updating I think I can even change the settings from the GUI.

Tried manually: error

connectwifi_000f54022506_424c42486f6d65_managed_pskError /net/connman/service/wifi_000f54022506_424c42486f6d65_managed_psk: Not registered

Tried again with the firmware from the above post (might not have been firmware though - not sure):

connmanctl> scan wifi
Scan completed for wifi
connmanctl> agent on
Agent already registered
connmanctl> services
*AO Wired               ethernet_b827eb764284_cable
BLBHome              wifi_000f54022506_424c42486f6d65_managed_psk
Belong7390A5     wifi_000f54022506_42656c6f6e67373339304135_managed_psk
BigPond09C2_     wifi_000f54022506_426967506f6e64303943325f31_managed_psk
connmanctl> connect wifi_000f54022506_424c42486f6d65_managed_psk
Agent RequestInput wifi_000f54022506_424c42486f6d65_managed_psk
Passphrase = [ Type=psk, Requirement=mandatory ]
Passphrase? ##########
Connected wifi_000f54022506_424c42486f6d65_managed_psk

Success! Didn’t think I could get it going.