Widevine at 1080p seems to be working or pi B3+

#1

Found this site with a repository for video test files…

https://www.matthuisman.nz/2018/05/kodi-widevine-support.html

Run the Widevine test video and it auto-installed a driver on launch. Worried that I just borked my Netflix plug in, I tested it and found it still working OK. Then, I rebooted the raspberry, set the video to 1080p and ran the pilot episode of Lucifer as a test. 45 minute episode and it briefly buffered once during playback. That sounds like a little overclock could fix it.

Asking for feedback from those with more expertise than me but, it seems Widevine support may be maturing on Kodi 18.

#2

The same library is used and it hasn’t changed in a while.

It sounds like your test clip may have had a lower bitrate than typical content

#3

Ok, one way to find out, I’ll try some other videos…maybe a Google Play movie as well…

#4

Ok, you were right. Black Mirror stutters just like it always did. However, there is good news. The repository installed an “Inputstream” plugin that can be tuned (on it’s own or from within Netflix). So, even though I got OSMC set to 1080p, I can tell it to stream Netflix at 720p. At least this allows me to keep SteamLink at 1080p without having to constantly reset the video resolution (or just live with streaming games at 720p).

#5

Because Netflix “newer” 1080p have terrible low bitrates they changed the encoding settings to “push” 4K only the 1080p HDR x265 is better at the moment.

#6

Yup, just checked. Lucifer is indeed HDRx265.

#7

Hmm. The Widevine test clip that comes with that repository (“InputStream Adaptive - Dash with Widevine”) runs with hardware acceleration, while Netflix stuff is decoded in software. Maybe it’s not a very good test.