Widevine issue?

I have a addon called spark sport which is currently streaming the rugby world cup in 1080p 60fps 7Mbps

At 1080p stream setting all i get is stuttering but when I bump it down to 720p it streams ok

I have been told the latest widevine is pretty cpu intensive and will have to wait until an update to it.

IS there anything I can do to get it to stream at a reliable 1080p 60?
Vero 4K

It’s probably unlikely that you’ll be able to get this to work at 1080p unfortunately


Try and update widevine now to 4.10.1503.4 solved a lot of streaming issues for me with Netflix and lightbox.

Thanks for the info.
I tried to update it on my Vero 4k but 4.10.1440.18 is the latest version I can get.

Which gives me really choppy playback

I installed it with inputstream helper app

I can’t seem to find the inputstream help addon in my Kodi.

This guide ?

Ok found and installed the helper but unsure what to do in its settings.
My widevine is still on the older version.

Install widevine again it will get latest version

Reinstalled and it’s streaming great.
Spark sport 1080p 50fps no stuttering

CPU usage way lower
Thanks :wink:

how/where do I check my current version of Widevine ?

k2u3’s request is seconded. :slight_smile: Could someone explain exactly how to check the installed version of Widevine, and how to update it if it’s not the most recent one?

Hi guys,

First you need to go into the Information page of the Netflix addon by using the context menu. Once there, go to Dependencies on the bottom, then down to InputStream.Helper.
Click on that, and press Configure. There you should see the Troubleshooting page.
If this does appear, go to InputStream Helper information where it should tell you what version of Widevine you have installed. If it’s not the most recent, on the Troubleshooting page you can go down to (Re)install Widevine CDM library, and update there.
If the Troubleshooting page doesn’t appear, you may have to update InputStream Helper. On the InputStream Helper addon page, instead of clicking on Configure, click on Update.

I hope this helps.


It does indeed. Cheers! :slight_smile: