Wifi 5g not consistently working

Hi all.
Trying to get my Vero4k connected to 5G Wifi. No success.

I had a look here: Vero 4K Will Not Stay Connected to 5Ghz Wifi - #2 by Tom_Doyle and tried the solution there. But in my case it does not work unfortunately.

When booting the Vero4K the OS, (in I’d say 50% of the cases), does not “see” the 5G connection. It is there, though. When it does see it, it works. But at the next boot it’s gone again. I could of course switch to the non-5G, but then sound is not syncing with the video. :frowning:

I have logs from before trying the solution above: https://paste.osmc.tv/lohaxihoci
And logs after trying that: https://paste.osmc.tv/hukupurotu

Any ideas?


Make sure you’re up to date and do a cold boot. There was a bug that caused this around August if I remember correctly

Thanks, @sam_nazarko, the osmc version is 2018.08-2. My osmc reports “no updates”.
I think the Vero is up to date.

Is there anything I can do from here?


When the 5g connection is not seen, have you tried disabling wifi and then re-enabling? I’m not suggesting this as the solution, its just if the 5g connection appears then; it may give in sight as to what the issue is.

Thanks Tom.

I have tried disabling and enabling several times. Mostly it does not help.

Weird thing is : the 5g-repeater upstairs is seen without fail by osmc despite its signal being very much weaker than the router’s 5g signal in the living room where the router and the Vero are. The Vero is positioned some 3 meters from the router.
Also (perhaps unrelated) : the myosmc screen with the network and wifisettings is terribly slow. Sometimes takes up to a minute or longer to show the wifi connections. Exiting the screen is also very slow.

Any ideas to investigate welcome, but I won’t be responding for the rest of the day. Need sleep.

Thanks for all your help.

Edit: also : I’ve rebooted the Vero several times throughout trying to get the 5g to work…


Is the repeater and the router, using the same wifi channel?

Thanks Tom.

Will have a look tomorrow.

From the first log:

Sep 30 16:41:28 osmc-vero wpa_supplicant[453]: wlan0: Trying to associate with b0:c2:87:e2:8c:57 (SSID='drdls' freq=2462 MHz)
Sep 30 16:41:28 osmc-vero kernel: Connectting with b0:c2:87:e2:8c:57 channel (11) ssid "drdls", len (5)
Sep 30 16:41:28 osmc-vero wpa_supplicant[453]: wlan0: Associated with b0:c2:87:e2:8c:57
Sep 30 16:41:28 osmc-vero wpa_supplicant[453]: wlan0: WPA: Key negotiation completed with b0:c2:87:e2:8c:57 [PTK=CCMP GTK=CCMP]

That’s a 2.4 GHz access point.

The second log includes this information on the attempt to connect to 5 GHz:

Sep 30 16:54:48 osmc-vero wpa_supplicant[439]: wlan0: Trying to associate with b4:ee:b4:92:d8:f7 (SSID='drdls5G' freq=5180 MHz)
Sep 30 16:54:56 osmc-vero kernel: CFG80211-ERROR) wl_is_linkdown : Link down Reason : WLC_E_DEAUTH_IND
Sep 30 16:54:56 osmc-vero kernel: link down if wlan0 may call cfg80211_disconnected. event : 6, reason=15 from b4:ee:b4:92:d8:f7
Sep 30 16:54:56 osmc-vero wpa_supplicant[439]: wlan0: WPA: 4-Way Handshake failed - pre-shared key may be incorrect

Please ensure that you’re using WPA2/AES encryption on the 5 GHz link. Also try a channel other than 36.

1 Like

True: if the 5G is not working I have to revert to 2.5G to be able to ssh into osmc and upload logs.

I have to put in the rather complicated password with the osmc-remote and the osmc password diologue (which doesn’t seem to have a feature to show the password in readable format), which is quite cumbersome - I did make a mistake once or twice. I think you are seeing one of these attempts.

Out of curiosity: is 36 a “bad” channel? Is there a reason not to use that channel?
I’ll look into how to change the channel number asap and report back.

Thanks for all your help.

Not sure. I’d have to look into this.
For now, I think I’ll remove the repeater, just to make the actual situation a bit less complicated and avoid any interference between repeater and router.

I have unplugged the repeater and I have set the router to 100/80. (Frankly, I don’t really know what this 100/80 means, but it’s not 36 :-)).

Will test the Vero tonight, and let you know what happens.


No, but it might have been a bit congested, hence the 4-way handshake timeout.

Just to be on the safe side, I’d also suggest that you stay away from “special” characters, such as umlauts, in your password.

A much easier way of entering the wifi password is via connmanctl in SSH.

now you tell me… :wink: I’ll look into that, but also: when your wifi is not up and you can not connect a cable to your Vero (as is the case here) there is no way to ssh into the Vero.

Repeater is off line.
Router set to channel 100/80.

Vero booted without problem, connected to the 5G.

Logs after boot: https://paste.osmc.tv/isafadehib

Will monitor the behaviour from here on.

Then you can try Plan B: attach a USB keyboard to the Vero4K. You can run into issues with the keyboard mapping of certain characters, eg £, #, @, since you can’t see what’s being displayed, but it will usually work if the password is just numbers and letters.

Thanks, would be much easier indeed, but the Vero is built in, in a box of sorts, which is screwed to the ceiling of the living room, so a keyboard is not quite that straightforward an option either… :confused:

Actually 36 is the best channel on 5ghz if you live in the EU. All other channels can potentially affected by radar. Only after switching to 36 my 5ghz became stable. If my router detected radar activity, it would shut down 5ghz wifi for 10 minutes except channel 36 because that is not used by radar. Of course if you live in a very densly populated area and everyone uses 36, then it is a problem again. But most people still don‘t use 5ghz or they use 5ghz with auto channel… so setting it to 36 manually is a great idea if you live in the EU.

Do you have a reference for this? Channels up to and including 48 are non-DFS, so I’d expect them to be unaffected by radar.

I just looked at the log file.

Sep 30 22:06:35 osmc-vero wpa_supplicant[455]: wlan0: Trying to associate with b4:ee:b4:92:d8:f7 (SSID='drdls5G' freq=5180 MHz)
Sep 30 22:06:35 osmc-vero kernel: Connectting with b4:ee:b4:92:d8:f7 channel (36) ssid "drdls5G", len (7)

Er, channel 36. :wink:

I don’t really know how to read those lines, but the log date and time you quote seem to point to yesterday. Any information in there with today’s date?

It says your Vero4K connected on channel 36, so perhaps it was still using the old connman configuration.

The time is probably carried over from the fake-hwclock. It changes once you get a working internet connection:

Sep 30 22:06:45 osmc-vero kernel: fb: osd[0] enable: 1 (kodi.bin)
Oct 01 19:02:24 osmc-vero systemd[1]: Time has been changed