Wifi adapter not recognized

And here are the relevant bits from dmesg:

[    2.358414] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[    2.460223] usb 1-1.2: New USB device found, idVendor=7392, idProduct=7811
[    2.460258] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.460276] usb 1-1.2: Product: 802.11n WLAN Adapter
[    2.460292] usb 1-1.2: Manufacturer: Realtek
[    2.460307] usb 1-1.2: SerialNumber: 00e04c000001
[    5.117630] NET: Registered protocol family 10
[    8.346758] cfg80211: Calling CRDA to update world regulatory domain
[    8.893002] rtl8192cu: Chip version 0x10
[   10.129483] rtl8192cu: MAC address: XX:XX:XX:XX:XX:XX
[   10.129537] rtl8192cu: Board Type 0
[   10.129796] rtl_usb: rx_max_size 15360, rx_urb_num 8, in_ep 1
[   10.129972] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin
[   10.185869] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[   10.200583] usbcore: registered new interface driver rtl8192cu
[   10.883713] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
[   13.730890] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[   13.731873] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   14.200756] rtl8192cu: MAC auto ON okay!
[   14.374085] rtl8192cu: Tx queue select: 0x05
[   15.350777] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[   15.544544] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   15.549215] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

And under Raspmc, the only bit in lsmod that I can see referencing the wifi is:

8192cu                458968  0

So this makes two of us :smile:

usb 1-1.2: new high-speed USB device number 4 using dwc_otg
usb 1-1.2: New USB device found, idVendor=7392, idProduct=7811
usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1.2: Product: 802.11n WLAN Adapter
usb 1-1.2: Manufacturer: Realtek
usb 1-1.2: SerialNumber: 00e04c000001
usbcore: registered new interface driver rtl8192cu

OK I’ve just followed DBMandrakes instructions in this thread: Enable wifi under GUI - #3 by ActionA

And the wifi is now working :slight_smile: Haven’t rebooted to see it sticks yet though

The config didn’t stay across a reboot

Configuring WiFi with connmanctl should be persistent


I think your problem will be with the rtl8192cu driver - one of my adaptors uses a chipset that needs this driver and it is very hit and miss for me on OSMC as well, (most of the time it doesn’t work) while another adaptor of mine with a different chipset works perfectly.

Raspbmc uses a much older Kernel than OSMC and it seems this driver is problematic on the newer kernels. We are still working to try to improve wifi driver support so watch this space.

One other thing to be aware of is we have set Ethernet to have priority over Wifi and only allow one active network interface - so if you have your Ethernet cable plugged in (as you do during your dmesg dump) wifi will not be activated. As soon as you unplug the Ethernet cable it should activate wifi however, if the wifi was previously configured.

I am working on improving the situation with modern kernels as this is an extremely common chipset.



Thanks Sam and DBMandrake, thats what I was hoping to hear :slight_smile: If you need an extra tester for this then let me know, I could probably build from source if necessary too.

I hope that this problem is related to Enable wifi under GUI - #8 by ferdydek

We’re talking about the same chipset adapter…

I havet followed the guide setting up wifi on osmc with connmanctl command.

After connect wifi_c83a35ca4314_535454657374_managed_psk
WiFi adapter starts blinking and I get to type in passphrase? Passphrase for my WPA password?

where do I type in my WPA password over ssh?

Passphrase is your WPA/WPA2 PSK password.

You would need to type it either via the local console or via SSH. (temporarily connected via Ethernet)

Note: if you try to do it via SSH over an Ethernet connection the Ethernet connection will be dropped when Wifi connects.

Thanks will try tomorrow :relaxed:

Thanks works!

Similar issue here. I followed the connmanctl instructions but when I get to the ‘connect’ step I

  1. have issues connecting and have to tell it to retry several times. And when if finally does connect
  2. it says ‘connected’ and the the raspberry pi freezes

This is for rtl8188cus

No one that I saw in this thread mentioned the pi freezing at that point. Everyone seems to either get it to work or they don’t even get to the ‘connect’ portion. So let me know what logs I can give to help out with this. I’m only minimally adept with Linux so I’d probably need to be spoken to like a child.

The joys of kernel preemption.

I’ve improved WiFi stability and performance a lot. Hopefully you will get to see this firsthand in the next release


Thank you. Well for various reasons I’ve been working on this for days with nothing but my phone and an ssh application. Of course shortly after I posted my problem I was able to borrow a computer and set up with the installer. So far so good. Just now looking into what OSMC has to offer.

Thank you for the response.

Does anyone know if Asus Dual Band USB-N53 will work?